Motherboard does not recognise CD ROM

  wobblymike 18:49 31 Aug 2003

I am trying to build a PC, my mobo (not sure what type but it supports PS2 K/B and Mouse and has Primary and Secondary IDE connections as well as Floppy) only has boot up options for Drives A and C, nothing for CD ROM, also on boot up, my CD is not recognised even though it is plugged in to the secondary IDE channel as master. In the BIOS there is an entry specifying what device is connected to secondary IDE, I have set this to IDE CD ROM - still no joy. I have used 3 diferent hard drives and using a 98 boot disc, F disk and formatted no problem - however I cannot then boot from CD to load windows. Can anyone out there help?

  howard60 19:54 31 Aug 2003

this could be an old bios problem. you may have to flash it. If you have the drivers try installing a dos driver for the cd. Also look in the bios for os2 op system and set for that, also set for pnp plug and play op system.

  hugh-265156 20:04 31 Aug 2003

click here the windows 98 bootdiscs here have generic cdrom drivers and tools included.also see click here

  harry_b 20:07 31 Aug 2003

is there a setting for auto for the drive type in the bios, also check cable is correct ie: red stripe to power and jumpers are right ( normally centre for slave and the right pin for master )

  woodchip 20:32 31 Aug 2003

It sounds like a very old Mobo. There should be a page in bios to auto detect the drives, if not try a double click on the drive. You have got the jumpers right I hope.

  woodchip 20:33 31 Aug 2003

PS also try a different cable, red wire toward the power plug and pin 1 on the Mobo

  woodchip 20:35 31 Aug 2003

Hears one not to use CABLE SELECT. Use Master and Slave as jumper settings

  Diemmess 20:41 31 Aug 2003

It sounds like a pre-pentium motherboard. Certainly one I had then, had a 486 CPU. The drivers for the CD (loading Windows 3.0) had to be installed separately.

No harm in experimenting but even if you load the generic drivers from a floppy, I feel this is the beginning of a list of problems.

  wobblymike 21:17 31 Aug 2003

Guys - Thanks for your thoughts, I have checked the cable exhaustively, I'm sure it goes deeper than that. I have loaded DOS driver, no joy - I'm going tp try to flash the BIOS as Howard 60 suggests but I'm beginning to suspect that it can't be done. Thanks again.

  Bodi 21:37 31 Aug 2003

If it is, then why not connect it as primary slave to your hard disk drive?

If it is an old CD-ROM drive - and I'm talking really ancient - some of these had to be connected to the sound card via a cable. The best generic driver for these was the Creative Labs CD-ROM driver.


  wobblymike 22:21 31 Aug 2003

Tried your suggestion and wired it up as primary slave - still does not recognise it - thanks for trying

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Moto G6 Play Review: First Look

iPad 9.7in (2018) review

Comment utiliser Live Photos ?