mother board hard drive controller

  jackdouglas7 15:30 03 Mar 2009

Dear all,
I have just put a new hard drive in my sons acer laptop as he kept getting,
"o200 failure fixed disk memory configuration error. Bank interleave requested but not enabled" when attempting to start up, which I was told was a hard drive fault.
The new hard drive worked ok for a couple of days but now has started giving the same message. I am returning the drive in case its another faulty one, but it has been suggested that it may be a fault with the hard drive controller on the mother board.
Any suggestions and if it is will I need a new mother board ?

  Stuartli 15:44 03 Mar 2009

You can either check that the laptop's motherboard drivers are up to date or, in Device Manager, Uninstall the Primary IDE channel and Reboot.

Might be wise to Uninstall the channel in Safe Mode, but I've done it in the past as described; the same applies to the Secondary IDE Channel.

You may also need to check out that DMA is still configured - running resetdma.vbs will save doing it manually. Download from:

click here

  jackdouglas7 22:15 18 Mar 2009

I have just fitted (for the second time ) a new hard drive in my sons ACER laptop as he kept getting "o200 failure fixed disk memory configuration error. Bank interleave requested but not enabled".

All seemed well for a couple of days but he has now, every so often,started to get " PXE-E61 media test failure, check cable" and will not start up .

Also is the boot order correct?
Its is as follows
IDE1:pioneerdvd-rw dvr-k16rs-(p
IDE 0: wdc wd1600beve-oowzto-(pm)
PCI BEV : realtek boot agent
USB Key:

  jackdouglas7 22:18 18 Mar 2009

Also Stuartli,
how can I check to see if the motherboard drivers are upto date, taking into account im not too IT?

  Stuartli 23:30 18 Mar 2009

Your bootup setting is OK.

Have you tried Uninstalling the Primary Channel and Rebooting?

Installing the latest motherboard drivers can only be of benefit. Go to the Acer website support pages and key the laptop model number into the search box.

  jackdouglas7 12:52 19 Mar 2009

I will check the Acer site tonight when I get home.
Ive not tried Uninstalling the Primary Channel and Rebooting yet. How easy is this to do ?

  Stuartli 14:51 19 Mar 2009

In Device Manager, highlight the Primary IDE Channel>right click>select Uninstall.

Then Reboot.

But I would try installing the latest motherboard drivers first.

  jackdouglas7 09:46 21 Mar 2009

I have tried everything that you have all kindly suggested but its still playing up. In despiration I have just ben to two PC repair shops and both have said that its a motherboard issue and that the to replace it would cost more than the laptop.
Any one know if its worth looking for second hand boards ?

  MAJ 10:52 21 Mar 2009

Disable everything in your boot menu except your hard drive, jackdouglas7, see if it helps. Also try disabling your network card in the BIOS.

  Stuartli 12:50 21 Mar 2009

How old is the laptop? Does it keep good time normally?

If not, it's likely to be a case of needing to replace the motherboard battery.

  jackdouglas7 15:35 19 May 2009

Dear all the fault was with the mother board which has died. A common acer fault so Ive been told.
New PC as a new board is so expensive.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Dell XPS 13 9370 (2018) review

The art of 'British' pulp fiction

Best password managers for Mac

TV & streaming : comment regarder le Tournoi des Six Nations 2018 ?