Modem won't work on a P200

  [DELETED] 17:26 26 May 2004

Just moved a Mercury 56k PCI Data/Fax Modem from a box running W98 on a PII 300 to another box running W98 on a P200. When I try to dial out using same cables, line and settings it eventually fails with error code 629. The boxes are sitting side-by-side. The P200 consistently fails and the PII 300 consistently connects.

I've meticulously compared Network and Dialup Networking settings and made the P200 identical (with the exception of computer name and file and print sharing.)

I've also followed the Windows troubleshooter and replaced the winsock modules (wsock32n.dll is missing on both systems and not present on my W98 disk).

One thought is that the P200 isn't beefy enough to run this modem but I can't find any info telling me the minimum cpu.

Apart from that I'm almost out of ideas. All suggestions welcome.

  [DELETED] 17:35 26 May 2004

Minimum System Requirements: Computer with Pentium 166 MMX or higher processor; Windows 98SE/2000/ME and XP Operating System; 20 MB Hard Disk free space or above; Sound card for voice features; 1 available PCI slot; CD-ROM drive

Note that it states MMX CPU and Win98SE.

Taken from click here

  [DELETED] 18:03 26 May 2004

Many thanks Eric10. Since this is a P200 with MMX I guess the CPU is not the problem. It's also W98SE and has 2G freespace.

Next stop is re-install Windows unless anyone else has a suggestion.

  woodchip 18:30 26 May 2004

It may have connected to the wrong Com port

  woodchip 18:31 26 May 2004

When you load the correct drivers it normally sets the correct Com port but it can go wrong

  [DELETED] 22:30 26 May 2004

Thanks Woodchip. Why would any particular Com port be right or wrong?

I notice on the PII 300 it's Com 4 and on the P200 Com 3 but I'm d**mned if I can find how to change it. I've tried uninstalling -reinstalling, but there are no options during this process that I can see for changing Com port.

There was an unused NIC in it that I took out but even reinstalling the modem after that didn't alter the situation. I also noticed IRQ 3 and 4 were reserved via the BIOS for Legacy devices but changing them to PnP likewise didn't alter anything.

Still struggling.

  woodchip 22:36 26 May 2004

There may be a jumper on the Modem card that will allow you to change the com port also a IRQ jumper. If it worked on Com 4 then it will not work on Com 3 unless you can alter the above

  [DELETED] 22:56 26 May 2004

In a pc I used to have I had to allocate Com 3 in the bios for the modem to work.

  woodchip 23:00 26 May 2004

If the card is fixed to Com 4 then you will have to force BIOS or windows for it to work on 4

  woodchip 23:02 26 May 2004

PS try deleting the Modem then install from Add New Hardware wizard choose to select from list it will then give you the option to set the COM port on 4

  [DELETED] 14:49 07 Jun 2004

Woodchip and PSF

Many thanks for your comments. It took me a while to run through all the options on this. In the end I've come to the conclusion that this modem will never work on this combination of board, processor and video card. It wasn't the case that it would only ever work on COM4 since I got it working on a third box on COM3.

In the end I swapped it for a Mercury Hardware Modem - Model VP156SPA, £15 from Silicon. If I'd known I could get a hardware modem so cheaply to begin with I would never have bothered with the original- Model HP156A, which has attracted a lot of negative comment in forums.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Best computer security tips

Best of the Grad Shows 2018: Central Saint Martins (CSM) illustration and graphic design

Best Mac monitors & displays 2018

Sécurité : comment protéger votre iPhone contre les pirates informatiques ?