Modem not detected after boot?

  nora123 07:31 04 Jul 2006

Recently i replaced my socket A ASUS motherboard with a socket A ASrock motherboard due to the ASUS becoming faulty. Ever since this change my motorola surfboard 5100 cable modem does not get detected after the pc is booted. The only way that it will be detected is if i disconnet the usb lead and then re-connect. I have tried installing the latest drivers from motorola, rolling back the driver, and uninstalling the driver and re-installing it, but nothing seems to work apart from physically disconnecting and then reconnecting the modem. Any ideas?

  Diodorus Siculus 07:57 04 Jul 2006

What about other USB devices? Can you try another USB port?

  spuds 08:44 04 Jul 2006

Did you install the drivers before or after connecting the modem, as this can make a difference to some set-ups. If you are using XP, have you tried the hardware wizard, and see if this detects the modem.

Another point worth considering. Is the modem connected through a direct usb port or via a hub, either self-powered or non-powered.

  nora123 17:18 04 Jul 2006

In answer Diodorus Siculus question:

Other usb devices seem to get detected ok, such as a memory stick or a digital camera. I have tried the cable modem in other usb sockets but it still doesn’t detect it.

In answer to spuds question:

It is a direct connection and I installed the drivers when the modem was connected. I have tried the hardware wizard but it still doesn’t detect it. Seems strange that everything works fine providing I re-connect the usb lead?

  chub_tor 18:55 04 Jul 2006

I think that spuds is on the right track. For most USB peripherals you should instal the software before the hardware.
I suggest that you uninstal the existing driver, remove the modem, reinstall the driver, then plug the modem back in.

  nora123 08:29 05 Jul 2006

I have now tried the following after uninstalling the driver for the modem:

1/ Attempted to install the driver without the modem connected. However, the latest driver I downloaded from Motorola consists of 4 files – .cat, .sys .inf and an uninstall .exe. I can only install these files if the hardware is actually connected (unless someone can tell me how). When I originally installed the modem there was no disc to load the drivers from. Windows just detected it.

2/ Used the hardware wizard and chose the “new hardware not connected” option. The guide then instructed me to switch off the pc and then connect the hardware. I did this and the modem was detected and worked fine! I then turned the pc off and on again but this time it wasn’t detected? Note: when I say not detected, the modem is visible in device manager but with an exclamation mark.

3/ Used the hardware wizard and chose the “new hardware is connected” option. After I had selected the modem (with exclamation mark) from the list it searched and then displayed “this device cannot start (code 10)” and directed me to the troubleshooter, all of which I’ve tried. None of the advice works apart from disconnectiong and connecting the modem when the pc is switched on? But like i've said, when the pc is switched off and on again, i get the modem with exclamation mark?

  spuds 09:20 05 Jul 2006

Best thing to do, is remove the modem 'completely' (uninstaller-add/remove-registry etc)from your system, and re-install from afresh.

You do not say if you have the 72 page instruction manual for this modem. If not, then you can download it as a pdf file from click here

In the instruction manual, there is from page 42 a troubleshooting section. Follow the instruction given there, and see what happens.

I do not know if Motorola modem as a technical helpline section in the UK. But I had need to contact their mobile telephone section once, and their advice and help was first class. So if all else fails, perhaps a email or telephone call will resolve the issue faster. The reason that I am saying that, is due to the fact that I have a Thomson/Alcetal SpeedTouch 330 modem. This modem was giving various problems, and it was only when I contacted Thomson, that it came to light that there was a confliction problem between my motherboard and the modem, in respect of the mobo chipsets.Easily solved, but it took Thomson's 'secret' knowledge to resolve the issue.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Dell XPS 13 9370 (2018) review

No need to scan sketches into your computer with Moleskine's new smart pen

WWDC history: Apple's product launches since 2005

Comment importer des contacts d’un iPhone à un autre iPhone ?