modem not answering

  farmboy 16:06 06 Apr 2004

i have re-formatted my hard drive, but it has now decided not to locate my internal modem, in the device manager there was two exclamation marks in yellow circles, pci communications device and audio device. The reasons it said for both of these prolems was that the drivers had not been installed. I clicked on modems in the control panel, and tried to locate my modem, but it would not, i then put in what i thought the modem was, an askey 56k modem. It tests the modem and says ok. But when i try to use the modem , a message says unable to locate modem. If i put the wrong modem in, will this make a difference. Also does the pci for the internal program need a program to run the modem. bASICAlly i get a error message telling me modem is not responding.
help, this is driving me up the wall. Also when i entered the modem in the control panel and put in what i thought the modem was, the exclamation mark in the other devices, in system devices, dissapeared.

  farmboy 16:10 06 Apr 2004

Can any1 tell me how to test a circuit board for an internal modem to see if its gone a bollock.?

if i put in the wrong modem will this cause big problems.

  Cuddles 16:25 06 Apr 2004

I would say the best option is to physically remove the modem from the machine and look for anything that identifies the make and model then look for the correct driver and install it.
Some modems are fussy about which port they configure themselves to, that could also cause problems.

  farmboy 17:54 06 Apr 2004

would a new internal modem sort the problem out? i have found out what the modem is, a pctel pct789t. Before though, the computer used to locate a pci communications device(my modem) on startup, but now it has stopped doing this, as if it does not know it is there. I have tried adding hardware in control panel, but it finds no plug and play and no non plug and play installed. i have downloaded the driver from, installed it and it seems to be ok, but the computer keeps telling me the modem is not responding and to check there are no conflicts, which i have checked and seems to be ok. Could my modem be knackered, will a new 1 sort out this problem?

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

AMD Radeon Adrenalin release date, new features, compatible graphics cards

Indie publisher Canongate’s top 10 book covers of 2017

New iMac Pro release date, UK price & specs rumours

Tablettes Amazon Fire : quel modèle choisir ?