Modem detection fails after SP2 install

  Blartfast 12:35 04 Dec 2005

My modem works fine with SP1. After installing SP2 the modem disappears from
the device manager. It cannot be detected by the add hardware wizard. I have
tried 2 different modems, both function correctly with SP1. Restoring back to
SP1 restores the functionality of the modem. The motherboard is a Microstar
6378 but no bios upgrades seem to address this problem.

  Gongoozler 14:03 04 Dec 2005

What type of modems have you tried? Are they internal or external, dial-up or broadband?

  Stuartli 15:20 04 Dec 2005

Try taking the modem out physically and then reinserting it, perhaps in a new PCI slot (I'm presuming it's an internal modem as you mention the mobo). Then reboot and reinstall the latest drivers for your model.

  Blartfast 15:57 04 Dec 2005

They are standard internal dial-up modems. I'm assuming there is actually nothing wrong with them as they work under SP1. I've tried different PCI slots. You can't install the latest drivers as windows can't find the modem to install the software for! Modems are not even listed in the device manager.

  Stuartli 18:18 04 Dec 2005

There's nothing to stop you installing the correct drivers first and then the modem, rebooting and allowing Windows (hopefully) to find new hardware.

Modems can be a real pain - I've spent many an hour trying to get them to work on friends and family's systems...:-(

  Skyver 18:41 04 Dec 2005

Look in the event log for errors relating to serial.sys. Can you create a connection to a COM port using Hyperterminal?

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

iMac Pro review

Illustrator Charles Williams on how to create magazines and book covers

iMac Pro review

Les meilleures prises CPL (2018)