Mobile Intel(R) 945 Express Chipset Weirdness

  Lyceaum 23:54 04 Jul 2013

Alright for starters

OS Version: Microsoft Windows XP Professional, Service Pack 3, 32 bit Processor: Intel(R) Core(TM)2 CPU T5600 @ 1.83GHz, x86 Family 6 Model 15 Stepping 2 Processor Count: 2 RAM: 1015 Mb Graphics Card: Mobile Intel(R) 945 Express Chipset Family, 1 Mb Hard Drives: C: Total - 76308 MB, Free - 13922 MB; Motherboard: Hewlett-Packard, 30AD Antivirus: None

Plus I will add to this that the computer is a HP Compaq NC6400 with a native screen resolution of 1280 x 800.

Now to the problem.

Recently I acquired this computer and everything worked fine, graphics were good and it had full max screen resolution. And it would play basically any game (except the most advanced ones running shaders) using its on board 945 chipset. At that point it was running some HP Graphics Control panel on start up, but I did not bother to check which one cause I was not going to mess with it at all.

Now as I said it was somebody elses computer before mine so I added and tweaked a few things, like upgrading its audio driver set, making sure flash, java, shockwave was straight, as well as that its had all the NET's, C+ and Silverlight installed and such, but nothing specifically graphic card / driver related.

Now I am not sure when it happened but one day I noticed the monitor looked different, and sure enough the max resolution now showed as 1024 * 768, and the HP graphics controller no longer showed. And I have since searched everywhere for a sign of its previous existence to no avail. But anyway since it was still performing well and I was busy I did not fret over it at the time.

Anyway now its got far worse, and now for whatever reason it wont support any advanced graphics at all, or play any of the games (with any detail) it played before.

Upon examination this is what I am seeing.

In the device manager / display adapters their are two entrys for the Mobile Intel(R) 945 Express Chipset. The bottom one is working fine. The top one has the yellow exclamation beside it indicating a problem. When I look for the reason it says (This device cannot find any hardware resources to use - code 12). Which is especially curious because what ever changes were made, no hardware additions or changes have been made since I got it, and if anything disabling things I did not need like printer ports and such would have freed up resources. But anyway

Upon running a dxdiag (because one of the games said I didnt have directx installed, which I know I had the latest, but just to be thorough, I get this.

While It does confirm I have the latest DX with all its files, but it shows nothing under display "Device" (resolution 1024 * 768) and the driver for this it has listed as vga.dll. Further more it says that it is incapable of any hardware acceleration for direct draw, direct 3d, or agp texture. Which also is very strange because I ran this test just a few days after I got it and all this worked well. Also checking under control panel, display, display properties advanced I get, no listed adapter and default monitor.

Now since then with the type of on board graphics clearly identified I have tried to reinstall the drivers several times, using different versions of the same type acquired both from the Intel website and the Hewlett Packard site. And even reinstalled every last one of the original NC6400 drivers that had originally been installed when I got it, in a desperate attempt to restore its original condition, but all to no avail.

Any ideas, and thanks in advance for your time and assistance.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

OnePlus 6 review

Procreate's iPhone app offers new brushes, a larger canvas and better support for the iPhone 8/X

Best multi-room speakers for iPhone & Mac owners

Streaming : comment regarder le lancement de Xiaomi en France ?