missing ntoskrnl

  iqs 16:09 27 Jan 2010

Had a PC which wouldn't boot and displayed the above message.
I typed the following via the recovery console,but it reported various reasons why the file could not be copied.
expand d:\i386\ntoskrnl.ex_ c:\windows\system32

Any ideas please

  johnnyrocker 20:21 27 Jan 2010

you may find something click here=


  iqs 23:16 27 Jan 2010

Hi johnnyrocker,
Thanks for the link.
For some reason when I was using the recovery console,it was not giving me the option to select the HDD/OS to repair.
Any thoughts?

  Sea Urchin 23:44 27 Jan 2010

This YouTube video will show you how to expand the missing file across to system32 - hope it helps

click here

  iqs 19:31 29 Jan 2010

thanks Sea Urchin,cheers

  Sea Urchin 10:56 31 Jan 2010

Did that help you to get it working? I notice you haven't ticked as Resolved yet.

  iqs 17:25 31 Jan 2010


Yes it helped,I now know have a better understanding of the recovery console.It works on my PC,but the PC with the fault still does not show a OS to select to repair.

Haven't had time to post back until today,the curse of work.


  Fruit Bat /\0/\ 17:52 31 Jan 2010

"the PC with the fault still does not show a OS to select to repair."

This and the fact you cannot expand ntoskrnl to the hard drive sounds like serious hard drive problems.

I would think the best course of action would be to fit the drive to a caddy or another PC and extract as much data as possible before going any further.

If you do not need any data off the drive then try running chkdsk from recovery console and then retry the XP repair.

  woodchip 17:54 31 Jan 2010

if you have os disc of the os do a repair after starting with the cd

  iqs 19:35 31 Jan 2010

I had all ready placed the HDD in a caddy,there was the usual windows folders listed .The user data was backed up,they now know who important backing up their data is.They nearly lost all of it..

I ran chkdsk when fitted in the caddy.Because no installation was listed via the recovery console,I could not enter any commands.
Thanks for the help

Tried a repair,but still no OS was detected.The option to repair was not listed,just the usual options when installing on a new HDD.
Thanks for the help

Still have no idea why the OS is not listed via rec console or the OS disc.

Thank you all for helping

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Samsung Galaxy S9 review

Artist Helen Friel on designing paper models for everyone to make

What to expect at Apple's 27 March education event

Idées cadeaux pour geeks et tech addicts