Missing memory in bios.

  c8 sdd 14:08 10 Oct 2009


I have four identical (new) ram sticks of 2gb each.

If i insert one only into my new gigabyte GA-G31M-ES2L mobo and boot it the first thing i see is my nvidia graphics card (8600 series) reporting its own 1024mb of ram ... then the next screen shows the amount of plugged in ram.

1047mb ... and thats it!!
I've tried each of my four cards, they all show as 1047mb each in p.o.s.t.

If i fill both dimm slots with 2x2gb ... the post screen shows 2094mb, not 4096mb or thereabouts.

Once into xp (32bit) i would expect the 4gb total to end up as 3-3.5gb, but no ... still only 2gb.

The board was bought from pc world with a dual-core cpu fitted, this was upgraded to quad-core cpu before i even switched it on.

I did use the supplied driver disk, although i would assume quad-core drivers would be on it as the box clearly stated the varients of cpu the mobo supported.

Any ideas?

  c8 sdd 14:11 10 Oct 2009

Just to add (confuse?) all 4 sticks of ram report 2048mb each when used individually on another machine!!

  OTT_Buzzard 14:44 10 Oct 2009

What make / model of RAM are you using?

What are the RAM settings in BIOS? To get full setting you need to press <ctrl> + <f1> on the first BIOS screen. Check the voltages and timings are correct for your specific RAM.

  Quiller. 14:53 10 Oct 2009

the memory is high density and your board does not support it you some times get no memory posted or only half of it. Also check the number of chips per side and refer to the motherboard manual for compatible ram.

Also check that auto/spd is set for the ram in the bios.

  c8 sdd 11:36 11 Oct 2009

The memory in use has the following labels: 2gb 800mhz 256x4 fg11/6n (No make though).

Ok, i've had a look in bios <ctrl + f1> brings up a few extras.

Basically this new gigabyte board has a dual-bios system where you can have about ten bios setups stored in a seperate area and can readily swap them into the working bios area.
There is extensive support for tweaking speeds ... its probably the most tweakable bios i've seen to date.

Anyway, the first thing i tried was to reduce the memory speed down to 667mhz (although these 800mhz sticks have been overclocked in another machine to 920mhz no problem).

Only half memory still showing.

Next, back in bios i switched the onboard video back on, then removed the graphics card ... still only half memory!

I think i should stop now and buy some <branded> 1066mhx ram as i'm running on 7 cylinders at the moment.

Here's the spec. on my mobo:

click here

  c8 sdd 12:03 11 Oct 2009

Just loaded a bit of software which came with the mobo's driver disk. (Dmiviewer).

Basically it displays various parameters on the pc.

Apparantly memory module A0 RAS 1 has 2048mb, memory module A1 RAS 2 HAS 2048mb.
The memory is there!!!

Also in dmiviewer the memory controller shows its maximum memory module size is 1024mb???

So how does one reach into the bios and enlarge this last number??

  carver 12:14 11 Oct 2009

That Mobo has on board graphics, have you disabled that before adding your card, because windows will allocate so much memory to running that.

Might be wrong but that could be the problem.

  c8 sdd 15:31 11 Oct 2009

On board graphics doesn't have any effect whether turned on or off, nor does pulling the nvidia graphics card.

I've been searching the net looking for info on this "maximum memory module size" as i think that could be the key.

  OTT_Buzzard 15:40 11 Oct 2009

The GA31-S2L boards do take 2GB modules - I have one downstairs in my media center!

  OTT_Buzzard 15:40 11 Oct 2009

G31M, even!

  OTT_Buzzard 15:50 11 Oct 2009

Download and run memtest (click here)

Unzip and burn the contents onto a blank CD.
Reboot and make sure that the PC boots off your CD drive.

It will test the RAM to make sure it's ok. Allow to do *at least* 2 passes, preferably 5.

It does take a while.

More info on memtest from click here

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Dell XPS 13 9370 (2018) review

HomePod review

Comment regarder les Oscars 2018 ?