Missing Ethernet Controller Drivers

  linsxxx 21:48 19 Nov 2008


Firstly thank-you for all the help I had re my hard drive a few weeks back. I have a new one now and am about to install it but first would like to get my wireless network up and running - just so I know it works really.

All my bits and bobs came from Tiscali but I haven't been able to get connected - they say it is a problem with my network card, not their router.

When I go into device manager there is a yellow question mark and next to it it says Ethernet Controller. I'm assuming this is my network card as it is the only thing that doesn't appear to be working.

Thinking that I had missed the driver when I reinstalled everything on my new hard drive I went on to Dell's website to get a driver for it. I have a Dell 2400 which is running Windows XP. I downloaded Network Drivers for my service tag for a "Broadcom 4401 Integrated NIC".

I have no idea what that is but again assumed it sounded more like an Ethernet Card than the others which said things like Video and Bios (?!)

Anyway I installed those drivers but I still can't get it to work.

So I'm thinking either:

a) they are the wrong drivers - how on earth would I know? How do I find out what gubbins is in there?

b) my card is broken. I mean I assumed they can just break somehow. Can you get new ones and if so what do I get?

or c) so other obvious thing that I can't imagine cause I don't know what I'm doing!

I've tried to use my initiative here and thought I had it cracked on the Dell website but am now totally baffled and no amount of Googling has helped so far.

All suggestions v welcome.

lins xxx (V frustrated!)

  Terminus90 02:34 20 Nov 2008

if thee is a new driver for your hardware, you will get it here.

  cream. 03:46 20 Nov 2008

They look like the drivers you have downloaded.click here

Download the drivers to your desktop, again. Go to device manager and right click the yellow exclamation mark. Selec t update driver and select the drivers in the folder for the updated driver.

Reboot the computer and then go to control panel, networks. Right click the lan connection and make sure it is set to enable.

Now try.

  linsxxx 10:03 20 Nov 2008

Ok I tried downloading the drivers to the desktop but I couldn't install them from there. It didn't recognise the zip file and when I extracted it, it automatically put everything in a folder it named under c:/Dell/Drivers.

I used that folder instead but it just said it couldn't find the right software and it didn't work. However when I rebooted my PC I now have a new modem ?! Under Device Manager / Modems I now have an:

Intel(R) 537EP V9x DF PCI Modem

which definitely wasn't there before (I always had a STandard 56000 bps modem which I presumed was my current broadband modem).

But my Ethernet controller still has a yellow question mark next to it. So maybe I didn't install the right drivers?

I don't know if it means anything but when I plug the ethernet cablr into the back of my PC a green light comes on. And when I switch the router on a yellow light comes on with it. No idea if that's significant.

Any idea what I'm doing now? Or why I now have a random modem!!

cheers lins xxx

  cream. 13:50 20 Nov 2008

"However when I rebooted my PC I now have a new modem ?! Under Device Manager / Modems I now have an:

Intel(R) 537EP V9x DF PCI Modem

which definitely wasn't there before (I always had a STandard 56000 bps modem which I presumed was my current broadband modem. "

That is for the old type of dial-up modem. You must have one in your machine. Just leave it. You may need dial-up in an emergency.

Back to the network adapter. In device manager. Select the network adapter ( lan ) under network controllers and right click. Pick uninstall and ok it. Reboot the machine and see if windows searches for the driver. Point it to the folder on the desktop.

******** make sure it is enabled in control panel - network adapters ********

Is it listed there????

  linsxxx 19:23 20 Nov 2008

I'm so sorry I feel like such a numpty. In device Manager there is a bit called Network Adapters. This has two bluetooth bits (which I know I have one dongle - don't know what the other one is), my Speedtouch modem and something called "1394 Net Adapter". I don't know what that is.

HOwever when I go into the Control Panel, Network Connections, the only thing that is there under LAN is this "1394 Net Adapter" (And it does appear to be enabled and it says "connected" too)

I don't know if that's my Ethernet Card or something else - it still says Ethernet Controller under Other Devices in the Device Manager.

Is it this 1394 thingy that I should uninstall and reinstall?

lins xxx

  cream. 20:55 20 Nov 2008

"I don't know if that's my Ethernet Card or something else "

1394 net adapter is for a firewire port. It is a communications port that can be used for a network but NOT for your lan.

In device manager / network adapters. Is that all that is listed? Is there any other yellow exclamation marks in any section of device manager and if so what are they listed as.

It could be that the lan is disabled in your bios. You may have to go in and check.

  T0SH 15:14 21 Nov 2008


Go to the folder where the drivers extracted to ("c:/Dell/Drivers" from your first post) open it and look for a folder that says something like Network ,Broadcom or Ethernet in the name, if any of these show open up that folder

"set it to show in Detail view" this way you will be able to see the files it contains

What you are looking for is a file with a .exe extension called Install or Setup if one of them shows double click on it should run the installer

If there is not any files as above then look for one or more with the extension .inf if any show use the Right mouse click and choose install from the menu if there is more than one .inf repeat with them all

Next go back to device manager where you see the yellow exclamation point beside Ethernet Controller ( Which is your network interface card) right click on this and choosing Update Driver should kick the installer into life

Cheers HC

  linsxxx 16:09 25 Nov 2008

thank goodness this forum is called absolute beginners or i'd feel even more stupid!

screaming baby distracted me for a few evenings. when i went back to it turns out i have a dimension 3000 - not a dimension 2400. hmm that's what comes of letting the dell website tell me what kind of computer i have rather than just looking.

screaming babies + computer novice not a good combo x

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Huawei MateBook X Pro review: Hands-on

The art of 'British' pulp fiction

Best password managers for Mac

TV & streaming : comment regarder le Tournoi des Six Nations 2018 ?