Microsoft XP Updates Grrrrrrrrrrr. !!!! No mouse

  reburner57 16:04 15 Sep 2003

Oh the joys of using Microsoft products.

The sequence of events was/is as follows

got the worm blaster
installed the original microsoft security update which corrupted a DLL file resulting in a stop error. Ended up reinstalling XP.
Having been Ok for a couple of weeks I decided i should install all the latest security updates (14 of them).
Did this yesterday and the machine crashed just as it was finishing the installation of the security updates.
Result was a Pc that wouldn't connect to the internet and didn't recognise my USB intellimouse

Restored back to before the security updates and now have an internet connection but still no mouse. The mouse lights up during the boot sequence but then dies as XP loads. Device manager shows no mouse present and searching for new hardware finds nothing.

Anyone got any ideas for how I get XP to recognise my mouse again.

This sounds to me like the USB drivers are not installing during boot. You dont have an Asus motherboard by any chance?

The initial flashing of the lights is the power to the USB and does not indicate that the USB drivers are installed or installing. Try using your Mobo drivers disk to reinstall those.

  Forum Editor 16:22 15 Sep 2003

it means that the BIOS is looking at the USB devices - do you have any others?

Have you got the mouse driver installed? Try running the installation again - from the CD that came with the mouse (you remember where you put that of course), and see if that does the trick.

  carlos 16:22 15 Sep 2003

I occassionally get this problem too, so reverted to connecting my USB mouse via a USB/PS/2 adaptor.Be interested to read of any permanent solution too

  choffe 16:27 15 Sep 2003

one thing i noticed is on msi motherboards bios setup page there is now an option for you to not use a mouse on usb, so i wonder if there is a known hardware flaw here

  reburner57 17:23 15 Sep 2003

didn't have the intellimouse Cd. It sort of came home from the office with me one day :) and worked fine. It's an MSI motherboard so will look at the BIOS tonight and will also check a non-usb mouse. The only other USB device I use is for my digital camera so will try that and post tomorrow with findings.

will also run the MOBO disc again

  Citizen -A 17:37 15 Sep 2003

intelimouse here

  Citizen -A 17:43 15 Sep 2003

No, I did not mean the intelimouse drivers, but the USB drivers for the Motherboard. Download them from the MSI site if you have not got the disk.

  reburner57 08:39 16 Sep 2003

Discovered last night that the problem is none of the USB ports are working.

I checked the BIOS and all the settings there appear OK

Will try and download the USb drivers for the MOBO today at work but don't understand why they should suddnly cease to work

Anyone got any other ideas ?

  AMD 4 ever 08:56 16 Sep 2003

Yep...uninstall all usb ports 1.1 and 2.0 from device manager, then reboot. Let them be found and either search the net for the drivers or install from your cdrom. Seems the only way.
Ake sure you have the USB Legacy enabled in the BIOS. It will allow you to use a USB Mouse/Keyboard without drivers etc...before windows loads.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Motorola Moto G6 review: Hands-on

The best smart speaker: Apple HomePod vs Google Home vs Amazon Echo

Les meilleurs jeux gratuits pour Mac (2018)