Memtest and USB drive shrunk

  bumpkin 15:28 28 Dec 2014

I downloaded Memtest to a 32GB USB drive with the intention of running it overnight. Not only will it not boot from it although USB is set as first device in BIOS but it now shows as 149MB. Is there any way I can recover it, tried format but would not do it. Also why did it not boot from it, I have EasyBCD installed if that is of any relevance,

  xania 16:49 28 Dec 2014

If you bought your storage media from a less than reliable source (i.e Ebay) you need to check that its has all it claims. There is a freebie program that you can download from this url:

click here program will confirm that actual storage capacity for you.

As to why Memtest did not boot directly from your USB, make sure that you watch the screen - it may first come up with the legend:

'Press any key to boot from ......' If you don't react in time, Windows will boot normally.


  Fruit Bat /\0/\ 17:00 28 Dec 2014

your usb needs to be made bootable

Rufus will do it easily

take the memtest file off the drive - refomat the drive - and make it bootable with Rufus - put the memtest file back on the drive.

also check the BIOS and make sure it is set to boot fom USB as first boot device or maybe something like F12 (10) (2) at power up allows you to select boot device.

  bumpkin 17:05 28 Dec 2014

Thanks for your reply, the stick has always showed as 32GB and I have had far more than 149MB on it in the past, probably 10GB plus. I was expecting and watching for the prompt but it just booted from the HDD. I will check out your link.

  bumpkin 17:07 28 Dec 2014

Missed that one Fruitbat while typing to xania, will try that next, thanks.

  bumpkin 17:57 28 Dec 2014

Thanks, I am working through your suggestions. Ran the tool from xania's link and the result was "Warning only 150923 of 305234 MBytes tested" and I fail to understand even what it means.

  bumpkin 18:39 28 Dec 2014

Rufus brilliant, sorted that in a few minutes now back to 32GB and bootable. Thanks Fruitbat. Before I destroy it again the reason I tried to use USB when I have Memtest on a CD is that I cannot get the thing to boot from cd/dvd drive whether Memtest or anything else. Nothing wrong with the drive itself and the bios settings have it as second after usb, won't work even if set to first. I know it is a bit off my original question but if anyone can help on that I would appreciate it.

  bumpkin 18:58 28 Dec 2014

Now what is going on, I seem to be jinxed lately. My 320GB backup drive was showing about 120GB spare this morning, now showing in red with only 1.8GB left. Dont't know if related to anything here but something amiss.

  bumpkin 21:26 28 Dec 2014

Backup drive D shows as almost full with red warning bar. Tried to format it but it will not format, instant message "Windows cannot format this drive" not like it has even tried to. The OS is running from C drive so not that. Gave up and shut it down, when I restarted it about an hour later everything shows as normal. Drive C and backup D about the same size. What the hell is going on here, failing drive? or memory issue or what. Just getting peed off with endless PC hassle over the last few weeks.

  bumpkin 22:59 28 Dec 2014

I just want to run a memory check, why is this IMPOSSIBLE.

  bumpkin 21:32 29 Dec 2014

The solution click here click the link unless you wish to download it.


This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Samsung Galaxy Note 10 Now On Sale: Price, Specification & Features

Best free Photoshop brushes 2019

Apple TV streaming service: what, where, when and how much

Les meilleurs écouteurs et casques audio Lightning (2019)