memory stick problems

  Boy Zone 09:18 26 May 2007
Locked

Just purchased a a new memory stick, and when I try to use it, it asks me to format it? It came with no software, and how do I format this.
When I go to my computer I can see the memory devise, but does not show the memory size. It's a unbranded stick.
Is the stick dead, as I thought all memory sticks came already formated!

  jack 09:38 26 May 2007

when display as a drive in my computer- do not attempt to open it- simply right click and then click format.

  Boy Zone 09:06 27 May 2007

tried this but it does nothing,

  Technotiger 09:09 27 May 2007

Hi, try it in a different usb port. While it is still connected have a look in Devices, see if there is an exclamation mark against it.

  Boy Zone 09:30 27 May 2007

tried this, it see the device as a generic volume device, I think it must be dead.

  Technotiger 09:32 27 May 2007

OK - go into devices again again and then right-click on it and click on Update Driver - just a chance this might work!

  Jonah(without the whale) 19:58 07 Jan 2008

I have just bought a memory stick from Staples. I can write to it and read it on my works computer but my home comupter running WinXP SP2 says that it can't read from the soucre file or disk - it appears as UDISK 2.0(E)
Any ideas please.
It looks to me that I have to change something on the machine, but what?
Cheers

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Dell XPS 13 9370 (2018) review

Creative studio Omnibus' brand identity for We Said Enough fights back against sexual misconduct

WWDC history: Apple's product launches since 2005

Espace de stockage : comment libérer de la mémoire sur votre iPhone ?