Memory stick - format not recognised error

  Luke4868 22:27 22 Feb 2018
Locked

Hi,

My friend has a SanDisk Cruzer Micro 4gb memory stick with his university dissertation on it (and yes this is the only copy). Something has happened to it and now Windows is saying it cannot recognise the format.

On further inspection is appears to have a corrupted partition. I've used various pieces of data and partition recovery software to try and fix the problem but none have worked at all.

So I've then tried TestDisk which also suggests the partition table was corrupt and suggested rewriting to MBR, which I did and also didn't work. Also tried rewriting the table under FAT32 and NTFS and it couldn't find any previous records or evidence of the partition details.

So then regrettable I formatted it and then tried data recovery again, hoping the files would still be there hiding under the new format, but this also hasn't worked.

Does anyone have anything further they can suggest I try? It's a near 200 page dissertation I'm trying to recover for him but at the moment I'm all out of options.

Thank you !

  Fruit Bat /\0/\ 10:49 23 Feb 2018

did you try Recuva?

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

EE 5G review: How fast is 5G in the UK?

Grad Shows 2019: The Best New Illustration and Graphic Design Talent from Central Saint Martins

MacBook Pro 15in (2019) review

iMac Pro 2019 : date de sortie, prix et fiche technique