Memory sticj not showing in Explorer

  [DELETED] 14:05 07 Feb 2006
Locked

I am running XP with SP2 and my MightyDrive 512MB stick isn't recognised with I plug into my PC. I have to go to Administrator/Computer Manangement/Disk Management and it shows up as Disk 1. At this point the stick is recognised in teh dialogue box and then appears at the same time in Explorer as my K: drive.
On my notebook, when I insert it, it gets recognised straight away. Also XP Home SP2.
How can I get the PC to recognise it?
Thanks to anyone
PvG

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Microsoft Surface Book 2 15in review

Illustrator Amy Grimes on how setting up her own eco-brand led to success with clients too

MacBook Pro keyboard issues and other problems

Test : l’enceinte connectée HomePod d’Apple