Major Registry Problem

  Loo Loo 02:20 27 Dec 2005

I cannot launch any programs (clicking a .ink shortcut freezes windows up, and clicking a .exe directly gives a 'permission' error).

I was running Ad-Aware SE Pro for the first time and tried Adwatch, and it soon bombarded me with 'registry key changes' which I told it to ignore. After a while I noticed all of my desktop icons had changed to the default no icon icon (you know what I mean). This was the same for my start menu and for all .exe files. I am pretty sure that the problem has stemmed from adwatch and this registry spree it had, as I run virus protection etc and had no threats reported so it's unlikely to be a virus I didn't know about.

I have managed to launch internet explorer by opening my documents and using the 'open with' option for a random file. I also managed this for MSN etc. I can also click an mp3 which will directly load into winamp, and click an image file which will open in my viewer, etc. So the problem is definitely in launching exe files directly.

I tried to run regedit from the run box in the start menu but as an exe it wouldn't function.

I'm really clueless with the registry, but I know if I have a txt file with registry info in it I can rename it to .reg and write the info to the registry. So as this is the case, I know this problem must be fixable without reinstalling windows. I assume it must be some kind of basic and obvious registry entry to do with program files that needs to be rentered / repaired.

I would really appreciate some help as I am utterly stuck now.

  AndySD 02:39 27 Dec 2005

What operating System are you using?

  Skyver 09:01 27 Dec 2005

Fix .exe association with this ; click here

  gudgulf 10:03 27 Dec 2005

If you are using Windows XP try using System Restore to a time before you used Adwatch........this will return your registry and other settings back to what they were.

  Loo Loo 22:39 27 Dec 2005

Andy, I am running Windows ME.

Skyver, that looks like exactly what I need but I can't run regedit, I've discovered .reg files are not associated due to the problem in the first place, and I cannot use 'open with' as it freezes up now too. Also tried running command from the run dialogue but it also would not start. Any ideas as ways around the main problem to get the info into the registry?

Gudgulf, I disabled system restore due to problems with it on my computer so that's not an option unfortauntely.

  VoG II 22:45 27 Dec 2005

Set your PC to boot from the CD drive click here and select the Repair option when prompted.

  Skyver 22:54 27 Dec 2005

Can you run regedit? If you can't, do a search for `REGEDIT.EXE`, make a copy of it called, run that and add the registry entries manually. I would recommend you ditch/upgrade from Windows ME as soon as possible too, if you can.
* Navigate to and select the following key:

HKEY_CLASSES_ROOT \ exefile \ shell \ open \ command

* Double-click the (Default) value in the right pane
* Delete the current value data, and then type:

"%1" %* [with quotes]

(ie., quote-percent-one-quote-space-percent-asterisk.)

* Navigate to:


* In the right-pane, set (default) to exefile
* Exit the Registry Editor.

  Loo Loo 22:56 27 Dec 2005

Skyver, that seemed like a perfect idea... except it turns out .COM extensions have also been messed with by adaware in it's hyper anti-malware spree, so I cannot run regedit in this way either. Is this looking like a hopeless problem?

  Skyver 23:06 27 Dec 2005

All I would do in that situation is make a backup or duplicate copy of `my documents` and *.dbx/*.wab files (outlook express), get your Windows ME disk and re-install. Ideally, if you had a DOS boot disk handy you'd load it and delete or rename your c:\windows\system.dat and c:\windows\user.dat files to stop ME picking up where it left off (with all the problems). Or try this one click here
Easier just to rename the Windows folder as `oldwin` and install over the top of your old setup.

  Loo Loo 23:17 27 Dec 2005

After some persistent googling (changing words, clicking countless useless links, going through other people's help forum posts etc) I came across something that made me consider a very simple option I had not tried.

And just for the information of anybody else facing this problem or for you guys who have helped me (if you'd like to know how the hell this was sorted!) here was my solution:

To repair programs:
Control Panel > Folder Options
'File Types' Tab
'New' Button
Enter .EXE, click 'Advanced', and choose 'Application'

To repair shortcuts:
Same as above, except:
Enter .LNK, click 'Advanced', and choose 'Shortcut'

Etc etc etc for any other broken extensions (I have a few like .COM / .REG which I'll sort out after I've posted this reply). Thanks to all of you guys for your responses!

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

AMD Radeon Adrenalin release date, new features, compatible graphics cards

Inside the iMac Pro - Apple's most powerful Mac yet

iMac Pro release date, UK price & specs

Comment nettoyer Windows et optimiser son PC gratuitement ?