Major issue following BIOS change - blank screen. BRICKED??

  smithdown 21:55 09 Aug 2012

Hey guys. I've hit upon a major problem and think I may have bricked my BRAND NEW PC. :-(

Specs: Asrock H61M-HVS motherboard, i5 2500k CPU, AMD HD 6870 GPU, OCZ 700W ModXStream PSU.

So, new PC, I installed Windows 8 Release Preview rather than buy Windows 7 and have to upgrade. Had a few problems, mainly with the graphics card not working. I tried updating all the drivers including the BIOS (to version 2.20 from here No dice, GFX card kept crashing. So, figuring it was probably a driver issue (with Windows 8 being unreleased, the drivers are still not out) I bought Windows 7 and have just installed it successfully. However, once installed it didn't recognise the ethernet adaptor, or the BUS drivers. So I thought I'd try rolling back the BIOS to v2.10 from the above link.

The BIOS update installed fine, initially. It said to restart the system, and when I did - blank screen. The fans etc are all whirring, but the mouse won't light up and neither will the keyboard.

Have I already bricked my new PC? Is there ANYTHING I can do? I saw someone mention resetting the CMOS by taking out a battery. Is this advisable??

PLEASE HELP!! I'm pretty new to this whole PC thing and this is my first real attempt at updating the BIOS etc.

  Fruit Bat /\0/\ 22:04 09 Aug 2012

If removing refitting CMOS battery doesn't work there should be a clear BIOS jumper on the board.

  KRONOS the First 10:41 10 Aug 2012

I feel you went about this the wrong way what with messing about with the BIOS.

I am assuming that a motherboard disk did not come with your new PC as that is all you would have needed to install Ethernet and BUS drivers.But you could also have downloaded the necessary drivers fom the Asrock site. certainly no need whatsoever to upgrade/downgrade the BIOS.

Following Fruitbat's advice it might be necessary to flash the BIOS following the instructions on page 40 of the motherboard user manual.Click here.

If you wanted to install Windows 8 it might have been worthwhile making sure that you had all the necessary drtivers to hand. Your graphics card does have Windows 8 drivers but there are still issues. See here. I think you were perhaps a little premature by wanting to go straight to Windows 8 as there are still driver issues and will be for a while yet.

  smithdown 11:09 10 Aug 2012

Thanks both. Yes I agree I went about it completely wrong. I should have just stuck in the driver CD from Asrock, I just jumped to conclusions that it was an issue with the BIOS update I had done which was released by Asrock to specifically counter an issue with Windows 8. As I said in my opening post - I'm new to all this!

Anyway, after posting the above last night I tried resetting the CMOS with the jump switch but it didn't work. So I removed the battery and replaced it this morning, and it booted up ok. So - its not bricked. Phew!! I have a picture and the BIOS has been reset to factory defaults. :)

I will try installing all the necessary drivers from the CD when I get home from work this evening.

Chronos - Thanks for the link to the AMD driver update, I hadn't found that when I was looking for updates on their website. That may have solved my initial graphics card problems. Sigh. Oh well, live and learn. This is all educating me about the correct ways to go around things!

Thanks again for your help.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

iMac Pro review

Illustrator of witty, relatable Instagram comics Julia Bernhard touches on our humble moments

iMac Pro review

Quelle est la meilleure application de podcast pour Android (2018) ?