Major Defrag headache

  jjss 14:21 29 Aug 2008

Good day one and All

I’ve just gone through a defrag of my IDE Maxtor HD which is in a USB caddy, on which is all my back ups. The defrag was interrupted and when I checked the data on the disk it had basically disappeared. When I check the properties for the particular disk it shows that, or appears to show, that all the data is still there.

I’ve re run defrag in the hope that it might solve the problem; the fact that I’m seeking help means that all is not well. Is there a reasonable way back so as to get to the “hidden” data?

My o/s is Xp Sp3 on a Toshiba Laptop.

Thanks in anticipation…


  woodchip 14:46 29 Aug 2008

Try running Disc Checker on the drive

  jjss 14:53 29 Aug 2008

Thanks Woodchip, I forgot to mention that one of the first things I tried was dskchg /f but thanks for your input.

  jjss 07:51 30 Aug 2008

Anyone have a thought?

  Technotiger 07:59 30 Aug 2008

A long shot, but is it possible for you to 'slide' the data onto another separate disk and then see if you can access it from there?

  crosstrainer 09:06 30 Aug 2008

Are you using backup software? (such as Acronis) If so, it will not defrag and should be left alone.

If these are just backups of your data, then try Technotigers' idea and try copying it to your machines hdd.

  jjss 13:47 30 Aug 2008

Sorry for the delay in returning, my Toshiba laptop is tied up running a "disk recovery" prog for the troubled HD (I'll let you all know if any good in due time). I'm on a very old Dell laptop struggling which is only just managing.

Technotiger: How do you 'slide' or is this another term for drag & drop?

crosstrainer: I do use Acronis on a different drive which I don't defrag. The trobled HD is data/music/pics only.

Thanks again for your input fellows


  crosstrainer 13:50 30 Aug 2008

Slide=copy. In other words, see if you can copy the files across, and access them from there.

If you CAN copy them, but not access the folders, check the attributes by right clicking, choose properties then advanced.

If the "Read only" tab is ticked, untick and try again.

  jjss 16:17 30 Aug 2008

Just to up date; "Disk Recovery" prog (Spinrite 6.0)proved the disk as okay but was unable to recover the data to a readable state. It took nearly 20 hours to do this, which would have been worth it if it had helped.

I tried copying some of the files across to my main HD as suggested... like Technotigger and crosstrainer said it was a long shot.

I'll tick as resolved and put this experience to one of those things in Live.

Thanks for your suggestions.


  Technotiger 16:28 30 Aug 2008

Ah well, can't win 'em all. Thanks for your feedback.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

AMD Radeon Adrenalin release date, new features, compatible graphics cards

8 brilliant character artists speaking at Pictoplasma 2018

iMac Pro release date, UK price & specs

Football : comment regarder la Ligue 1 en direct ?