Mail merging emails with Word 2007

  Gary Wood 20:08 03 May 2008

I am using Microsoft Office 2007, and trying to mailmerge to emails from Word. I used to be able to do this with Office 2003 without any problems.

In 2007, when I have finished creating the merge and click "Merge to emails", I get the following warning:

"A program is trying to send an email message on your behalf. If this is unexpected, click deny and verify your antivirus software is up-to-date."

This appears for each message that is merged, so if I'm writing to 50 recipients, I see the message 50 times!

Is there a way I can set Outlook to trust Word, or some other way to avoid this message?

Many thanks,


  Taff™ 08:09 04 May 2008

Hi Gary! Where is this message coming from? I used to get the same from Avast Anti-Virus when doing this and the answer was to disable the Outlook plug in provider component temporarily.

  Gary Wood 10:32 04 May 2008


Thanks for your reply. I _think_ the message is coming from Outlook itself, because the title bar says "Microsoft Office Outlook". Also, there's a "Help" button and when I click this, it takes me to the Microsoft website (though just to the general help section, not a specific page!)


  VoG II 10:43 04 May 2008

If you were doing this programmatically then you could use Outlook Redemption click here but I don't think this will help with a manual mail merge.

You could try a search here click here

  Taff™ 13:02 04 May 2008

Do you have Zone Alarm installed? I would try disabling any firewall and AV and see if that works. (Test by switching off the automatic immediate send of e-mails so that the test merge remains in your outbox, so you can delete them from there.)

  Gary Wood 14:20 04 May 2008

Thank you for your replies.

VoG™ - I've tried searching the site you linked to, but couldn't find anything. I've also tried searching with Google, but didn't find a solution.

Taff™ - No, I don't have Zone Alarm. I use Norton Internet Security 2008. However, I'm almost certain that it has nothing to do with this, because the message I see is generated by Outlook.

I see two messages when I run the merge to email, both from Outlook. The first says that a program is trying to access address details stored in Outlook. It gives the the options Allow/Deny, and I can set a time period, e.g. Allow for 10 minutes, meaning I only see this message once per merge.

The second message is more problematic, because I see it once for every email that is generated by the merge, and have to click Allow on every one! This is the one which says a program is trying to send an email.

I've looked through Outlook and Word extensively to try and find a way to turn it off. Obviously, it's a security feature, and I'd leave it on most of the time, just switching it off when I want to merge, but there doesn't seem to be a way to do this!

I'd be very grateful for any other suggestions, because it's making mailmerge fairly useless at the moment!



  VoG II 14:27 04 May 2008

Try Tools > Trust Center > Programmatic Access.

  Gary Wood 19:08 04 May 2008


Thanks for this. I looked at the settings you suggest in Outlook, and from the description, it certainly seems like these should solve my problem. There's an option to turn off notifications of this type. However, I did this and then tried mail merging again, and still got the messages! So, either these features relate to something else, or they don't work the way they should! Did you manage to get them to work?

Thanks again for your continued help.


  Gary Wood 11:03 10 May 2008

Just wondering if anyone else has had chance to try out changing these settings? I ran another mail merge yesterday, but even with the Trust Centre settings changed in Outlook, I still had to approve the sending of every message the merge generated!



  PC Doctor Dave 10:11 18 Jun 2008

Please see click here for details about this issue.

Quote 'When you create a mail merge to e-mail or fax by using your Contacts folder, you must eventually use Microsoft Word to complete the mail merge. After you start the actual merge, you receive a warning message which indicates that a program is trying to access your address book. You can allow access for up to 10 minutes, and you do not receive address book warning messages again for that period of time. However, a separate warning message for each e-mail message that you send appears and you must wait five seconds before you can confirm the send process. For example, if you generate a mail merge to e-mail that is being sent to 100 people, it takes over eight minutes and you must approve each of the e-mail messages every five seconds. This is a limitation of the current design and improvements are being evaluated for the next version of Microsoft Office.'

  Gary Wood 10:45 18 Jun 2008

PC Doctor Dave,

Thanks for this. I never did get to the bottom of this issue, and the page you link to explains why.

I sincerely hope that Microsoft will release an update to fix this, rather than waiting until the next version of Office is released.

In the meantime, I guess next time I want to do mail merge, a good solution would be to use Virtual PC and run Office 2003 on that.


This thread is now locked and can not be replied to.

Elsewhere on IDG sites

iMac Pro review

25 book design and illustration tips

iMac Pro review

Idées cadeaux pour geeks et tech addicts