Macrium Reflect Update Problem

  olyman 08:20 18 Aug 2014

When I tried to update the latest Macrium Reflect Free I got a message saying”Verify that you have sufficient privileges to start system services” I have tried again running as Administrator with the same message. Anyone else had this problem and solved it?

  john bunyan 08:50 18 Aug 2014


I use it on one laptop - ok last week making an image. Will look again later. I find it not as easy as ATI, but at least it is free! Have not found a "verify" procedure as in ATI.

  Batch 09:03 18 Aug 2014


I don't see any great need to keep updating such software. If the version you have works (for you), why update? I'm currently using V5.2 Build 6354 (with Win7), I use it frequently and never have any issues.

And I still use ATI v8 on my XP PCs and it has never let me down. The only reason I switched to Macrium for Win7 was that I wasn't certain that ATI8 would work under all circumstances with Win7 as it was never developed with that in mind.

john bunyan

Verify: click on the Restore tab, then against each image listed there should be a number of options, one of which should be Verify Image.

  olyman 10:07 18 Aug 2014


True enough but I was intending to restore to an early image, hoping to regain performance. The only saved downloaded exe file that I have is for Reflect V5.0 build 4033 which is much older than V 5.2 6354, my current version. For some reason the exe file for the latter hasn't been saved. I would have preferred to install the latest version on a restored image.

Incidentally I have replaced the main HDD since backing up the image. Will the change in hard drive size create problems in restoring?

  Batch 11:03 18 Aug 2014

You could try downloading from somewhere like FileHorse

Select the edition you want (32 or 64 bit) and then you are able to select older versions.

I can't vouch for the site in any way though and I'm not 100% sure they are the free version.

1]: [click here

  olyman 11:22 18 Aug 2014

The File Horse version is listed as freeware and the exe file has free in it's title but when I tried installation it turned out to be a free trial.

  olyman 11:44 18 Aug 2014

I finally got a working version from the CNET site

  Batch 11:47 18 Aug 2014

One could go one forever like this, but......

There's also one on file hippo: click here

Again, can't be 100% certain it is the free one. But the file size (43,712,632 bytes) and name shown on the Technical tab is exactly the same as the the free copy that I have.

  john bunyan 12:31 18 Aug 2014

Given the choice, I would choose Filehippo every time over CNET, as I have fould them very prone to sneak unwanted stuff with their downloads. I have taken to downloading the programmes and, prior to running it, do a scan with malawarebytes. Only yesterday I found one in a downloaded programme and deleted it (think it was conduit search)

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Google Pixel 3 review

Automatically create thousands of unique variations from one original design with this Illustrator…

iPhone XR release date, price & specs

Test : le Razer Phone 2