Lost Logitech Keyboard

  ened 14:23 02 Mar 2009

I decided to plug in my new Logitech Desktop LX710 keyboard.

Clicked the connect button on the dongle and the connect button on the board - Nothing.

Tried to revert to my old LX700 and that won't work either.

Both receivers are connected to the machine.

Device manager shows Two Unknown devices - Disabled. Enabling them made no difference. I have the latest Setpoint Software but that shouldn't matter becaue they should give limited functionality without it.

I am probably being really stupid and missing something obvious but can any one help?

  harry12 14:48 02 Mar 2009

If mouse/keyboard were installed after powering up this could be problem as they will only be recognised at startup.

  ened 14:51 02 Mar 2009

I thought of that and did a reboot which left me unable to boot beyond the password. I had to plug in a ps2 board to be able to boot.

I'm sitting here with the ps2 and nothing else can be recognised.

  mammak 14:53 02 Mar 2009

Hello ened, we recently had a problem with our Logitech XS 100, it was working fine for a few months and after a battery change it wasn't even showing in device manager, I just reverted to my wired keyboard.

I have read since that there could be a reset button on the back of the keyboard? I couldn't locate one on my model but you could try yours and see if it works.

  ened 15:03 02 Mar 2009

As i sit here I am pussing the (red) button to which you refer.

There is something strange here because my LX700 was working fine until I tried to install the LX710.

  mammak 15:24 02 Mar 2009

Hello again ened, I have now tried again with my model, like yours the software/drivers were all up to date, I thought they might be referring to a reset button such as a router has? but seemingly not.

However I have now noticed a sleep button (my model is f10) which after fiddling with that a few times it now works again.

  ened 15:40 02 Mar 2009

I have managed to re-establish the status quo in that I have managed to regain the use of my LX700.

However the LX710 will not work, with the exception of the Mail key. Actually I first noticed the Mail key would open Windows Mail then I noticed the Music key opens Windows Media Player and I have just freaked out because after reading mammak's last post I pressed the moon key.

This put the machine into some kind of sleep state and, initially, I could not revive it.

So it is connected but only some keys work and it is not showing up in the notification area. In Device Manager my LX700 is showing but the new one is 'Unknown Device'.

Any other ideas?

  ened 16:46 02 Mar 2009

I have now tried the mouse which comes with it (I hadn't wanted to use it because I already have a better one) and that won't connect either.

When I press the red button on the dongle a message comes up instructing me to press the red button on the device.
So I know there is not a problem with the usb port.

I still can't help thinking I am missing something obvious.


  mammak 19:22 02 Mar 2009

Hi ened, on my keyboard the button in question has an apple type pic on it,this is all getting confusing now as I'm on my laptop at the moment,but the keyboard we are discussing is on the desktop, and the boss is using it (my 12 yr old :-()

Anyway try uninstalling everything, and reinstalling again, but if they are both wireless then there might be some sort of conflict going on here?

  ened 07:05 03 Mar 2009

I have been through everything I can think of and I don't think I have done anything stupid or am missing anything obvious.

You could well be right about a conflict but that will be a last resort because when I installed the Revolution the whole machine crashed and then the mouse would not work. I eventually managed to get it working but do not know how. Therefore I am loathe to uninstall the Setpoint software in case that happens again.

I have contacted Logitech support and am awaiting a response (hopefully today).

Perhaps you could ask 'the boss ' about my problem?

  ened 15:58 03 Mar 2009

I've just persuaded my wife to let me try this on her lappy and it worked straight away so the problem clearly lies with my machine.

It looks like I shall have to uninstall all the software and start again.

At least I know for certain the new board is not faulty.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Honor 9 Lite review

How Social Media has Propelled Political Graphic Design and Art in the Last Decade

The best kids apps for iPhone & iPad 2018

HomePod d’Apple : date de sortie, prix et fiche technique