Lost IDE Channels

  Professor Plum 16:26 07 Nov 2003

Hi people, I am having a problem,

I have the Primary Master channel, but nothing works on the Primary Slave, Secondary Master or Secondary Slave channels. I have tried several different cables, 2 CD Rom Drives, 2 DVD Drives and 3 Hard Drives in different combinations of Master/Slave none will work, so I am sure it is not a problem with drives or cables.

Can you advise what else I should look at !!


  TBH1 16:35 07 Nov 2003

firstly, when you try putting things on primary/slave, do you have your system disc on primary/master? Disks have jumpers on the back to tell it whether its a slave, master and sometimes whether its a single disk. Maybe your disk is set up as the latter and needs jumpering to primary/master before things are recognised on primary slave.
Spookily enough, last weekend nothing was recognised on my primary ide channel - - it turned out that the disk on primary/master had gone to meet its maker - still don't know why it didn't pick up the primary/slave - - probably confused you now ain't I ??

  Rtus 16:35 07 Nov 2003

and the entries in the bios read ? auto?

  Professor Plum 16:47 07 Nov 2003

Primary Disk is correct. I have tried the changing the jumpers, and the bios entries are on auto.

  DieSse 17:06 07 Nov 2003

If you are SURE it cannot be a problem with the drives or cables - then it can only be the motherboard! - because there isn't anything else.

Have you checked each item out in DOS - in case it's a Windows issue?

Getting jumpers correct may be trickier than it appears with some units.

Are you using 80-wire cables - have you tried setting devices to "Cable Select" - then the drive at the end of the cable will be the Master, and the one on the centre connector will be the Slave.

How do they show up in the detection box at the end of the POST?

Is this a new or old system?

  Professor Plum 17:26 07 Nov 2003

Absolutely sure drives and cables ok.

Bios detects drives!

Just checked in DOS, DOS does not recognise them!!

  SGT BARNES 17:36 07 Nov 2003

if you are using dos in windows and that doesnt find them but the bios does then its got to be a problem with windows

  DieSse 17:40 07 Nov 2003

BIOS detects the drives -

Then maybe they're not setup properly for DOS to find them.

Optical drives will not be detected in DOS unless there are appropriate drivers loaded.

Are all hard drives properly set up - fdisk'd and formatted?

Sometimes corruption in a hard drive's MBR (Master Boot Record) can stop it being found by DOS. You can run fdisk /mbr from a boot floppy to correct this.

  Professor Plum 17:43 07 Nov 2003

I booted from a Win98 startup disk for the DOS check.

Cant do a new windows installation, CD Rom not recognised!

  Professor Plum 17:49 07 Nov 2003

I have tried 3 different Hard drives all setup and being regularly used. No Hard drives or Optical drives other than primary master is recognised!


  DieSse 17:58 07 Nov 2003

AS touched on earlier - is it possible the primary master could be stopping anything else from working - or have you covered this possibility?

If so then either you're doing something wrong that I can't tell - or your motherboard is faulty. There's nothing else.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Motorola Moto G6 review: Hands-on

The best smart speaker: Apple HomePod vs Google Home vs Amazon Echo

Les meilleurs jeux gratuits pour Mac (2018)