Lost Administrator Rights in XP

  Snrub 02:04 27 Jun 2009

I have lost administrator rights tried various means to re-establish them but nothing works in user accounts, msconfig, safe mode etc. Is there a registry way of tackling the problem?

  mgmcc 08:10 27 Jun 2009

Windows XP *SHOULD* always have at least one Administrator account and this cannot normally be deleted or downgraded unless a second Administrator account has been created.

However, try booting into "Safe Mode" where you can log in with Windows' Default Administrator Account (provided it wasn't password protected when Windows was installed) and use that to set your own account back to being an Administrator account.

  Snrub 19:19 27 Jun 2009

Tried that it says 'Access Denied' even though I have always been the one owner and administrator. This is only a recent problem have always been able to access account previously.

  griffon56 23:51 27 Jun 2009

Hi Snrub, I've just had a similar problem trying to get rid of the 'Welcome' screen and had to go back to a restore point in order to gain access again. You probably know the drill. Get into 'safe mode' and choose the relevant option from the first menu.

There is an option in 'Control Panel - User Accounts' to 'Use the Welcome screen', I unticked it and on restart the machine wouldn't give me access unless I'd entered a user name and password, something I'd never set up because I'm a sole user and administrator. Perhaps this has somehow been unticked in your setup. Good luck.

  Snrub 12:34 07 Jul 2009

Still havent solved this problem despite many attempts in safe mode. It shows I am the Administrator and then tells me access denied when I try to alter things like "start up" in mscofig.

  fishmad pete 13:43 07 Jul 2009

I see in your last post that you have lost administrator rights when using msconfig. I too have an error message coming up when I make changes in msconfig saying that I need to be the administrator. However any changes I make are applied so I just ignore the error message.
If you can't change anything at all because of lack of administrator rights then you may have had a virus. Carry out a virus check using an up to date virus checker (Mcaffe Stinger).


  fishmad pete 14:07 07 Jul 2009

Further to my last post. I have just done a search and found that my particular problem may be down to Mcafee security software. Several posts on the Mcafee web site seem to confirm the exact problems I am getting. As yet there appears to be no solution (except uninstall Mcafee)


  Snrub 16:22 07 Jul 2009

Thats very interesting because I downloaded McAfee security software a month back as part of BT Option 2 constantly pestering me to update to this package as BT NET PROTECT. I had so many problems with McAfee because its not user friendly with other products and let a virus and a trojan through which Malwarebytes removed. It was a real nightmare so have reverted back to AVG 8.5, Spybot and Outpost. Although I have deleted McAfee I notice in Autoruns and Process Explorer that bits of McAfee are left on. Now fully checked for viruses and trojans and comes up ok but left with no Administrator rights.

  fishmad pete 17:04 07 Jul 2009

There is a download from Mcafee that should remove all reference to their products in the registry and I believe should restore your administrator rights. However I can't find the link at the moment. When I do I'll post it here


  Snrub 18:02 07 Jul 2009

Thanks that would be great, look forward to receiving it.

  Sea Urchin 22:14 07 Jul 2009

Here it is

click here

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Dell XPS 13 9370 (2018) review

The art of 'British' pulp fiction

Best password managers for Mac

TV & streaming : comment regarder le Tournoi des Six Nations 2018 ?