Long Wait for Shutdown

  Anti_Virus 14:10 17 Nov 2004

Hi, I'm running Windows XP SP2, and have a 60GB hard drive with 1.7Ghz on the system. At the momement, because my systems fairly new (a couple of months), I take real good care of it. I defrag once a day (I'm a bit paranoid ;) and all that. I've been really happy that it's been so fast, until, about teo days ago, it's been taking 5 minutes for Windows to shut down. I don't know what the problem is, so I'd appreciate any help anybody can give.

  ACOLYTE 14:15 17 Nov 2004

Windows has to close running programs before closing down so have you got a lot of programs running you dont need?You could try cleaning the temp internet folder and clearing some restore points you dont need.And dont have as many things loading at windows start up,that way there wont be a lot to close at shutdown just use them when you need them.Also try a spyware scan.

  Brian-336451 14:56 17 Nov 2004

When this has happened to me I usually run the command Start>Run>sfc /scannow which replace any rogue files slowing the system down.

  Jackcoms 16:54 17 Nov 2004

Try this. It does sometimes seem to be a problem after installing SP2. I used this method myself some time back. It will take about 8-10 seconds for Windows to close after the fix:

1- Start/Run and type Regedit
3- Click on “Control folder”
4- Select “Wait to kill service timeout”
5- Right click and select “Modify”
6- Set to a lower value than 2000
7- A setting of 200 will be sufficient

Normal setting is 2000 but can safely be reduced to 200 for a quick shutdown. In one or two systems that I've checked including my own an extra nought was added on to make it 20000. Not sure why this happens but when it does it leads to a very long shutdown time.

  Djohn 17:28 17 Nov 2004

Start/run and "TYPE"


From here on be very careful not to make any changes unless you feel sure of what you are doing.

Look in the left-hand pane of the two panes on show. Click on all the "-" sign's to collapse your folder tree back as far as it will go.

Now all that should be showing is "My Computer" Icon with a + sign to the left of it.

Click on the + sign
Scroll down to the HKEY_LOCAL_MACHINE
Click on the + sign to expand that folder.

Scroll down to the SYSTEM folder and click on the + sign to expand.

Scroll down to the "Current control set" and click on the + sign to expand.

Scroll down to the "Control" folder and click on the folder itself.

Now look to the right-hand pane of the window and you will see.

"Wait to kill service" Icon.

Right click on that Icon, from the drop-down menu choose.


Left click on "Modify" and dialogue box will open with the figure 2000 or 20000 inside it.

Reduce this to 200 by left clicking to the right of the last zero then backspace to delete one of the zero's or highlight the whole number and change to 200.

Click on OK and back your way out of the registry saving as you go.

It's easier than it sounds, but take your time and go through it slowly and you will be OK. If at any time you feel unsure just back out without making any changes.

Remember to collapse your folder tree as I mentioned above then you can start right at the beginning and follow through.

PS: Print this off first then you can follow the guide.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

iMac Pro review

25 book design and illustration tips

iMac Pro review

Idées cadeaux pour geeks et tech addicts