Logitech Quickcam 9000 fails to activate

  tallboy 21:12 23 Oct 2009

I recently installed a new Logitech Quickcam 9000 to use with Skype, Messenger etc. All went well initially and it worked fine. However, when I came to use it today it would not work with any of the communication applications.

I accesed the camera directly using the camera & scanners function in the Control Panel and got an XP error message 'Windows Explorer has encountered a problem and needs to close'

I then went to the Hardware Device Manager under the Systems function in the Control Panel to check the driver. This reported that the device was working properly, when clearly it is not!

I then contacted Logitech technical support and they advised me to remove all the Logitech software, download the latest application and driver from their website and re-install it. They assured me that this should fix the problem.

I did this (running several registry cleanup sweeps after removing the software, using Advanced SystemCare, Registry First Aid and Registry Mechanic) and commenced to re-install the application & driver.

All went smoothly and I connected the camera at the appointed time. I then got an image from the camera, which at least proved it could work, as it got to the point in the setup where you make minor adjustments. I then let the installation finish at which point it told me the camera was set up and ready to use.

Following this, I attempted to use the Logitech Vid communications program to try out the camera. To my frustration, it still didn't work! I went back to the Control Panel Scanners and Cameras function to try and start the camera from there, but sure enough, I got the same Windows Explorer error message again.

I have tried plugging the camera in several different working USB ports, but to no avail - it still doesn't work.

The only thing I can think that might have affected it is the fact that since I last used the camera successfully, I have updated the drivers for my USB ports using the DriverMax application. Would this be causing the problem, even though the Device Manager reports it as working OK? (I have also discovered that my add-on USB 2.0 card is currently not working, so this might point to updated driver problems - although the 'regular' USB ports work OK with other devices plugged into them)

Suggestions as to how to identify the problem and get it working again would be most welcome.



  Technotiger 21:31 23 Oct 2009

What happens if you check the Video Options within Skype?

I too use the Pro9000, best webcam in existence as far as I am concerned.

  tallboy 22:22 23 Oct 2009

You get a black screen (where the image should be) followed by the error message 'Skype has encountered a problem and needs to close'

I agree with your comments about the camera - it is excellent (both our children have them in their homes) - which makes it even more frustrating that mine has ceased to work!

  Technotiger 22:28 23 Oct 2009

Can you try the cam on a different PC? or perhaps try one of your children's cams on your PC?

Of course, the cam itself could be faulty, perhaps you should return it for replacement with one that works.

  Stuartli 23:57 23 Oct 2009

It's not unknown for Device Manager to state that a device is working properly, only to discover that the reality is different.

Is the webcam Enabled from the drop down menu and/or defined as the Default imaging device?

  BRYNIT 00:18 24 Oct 2009

I don't use a web cam but reading what you have tried it looks as though the problem may be elsewhere and not with the web cam I could be wrong.

Have you considered a possible problem with Skype or Messenger. Try uninstalling them and then reinstalling one at a time. Check that you have the latest version of Skype.

Looking through the web it looks like other people are having a similar problem click here

  tallboy 09:31 24 Oct 2009

Thanks for the suggestions Technotiger, Stuarli and Brynit. My next move is to try it on my wife's since our children live 500 miles away and hence it is impracticable to borrow theirs.

Previously I have had the camera working directly from the Scanners & Cameras function in the Control Panel, so I don't think it is any of the communications apps.

If it works OK on my wife's PC, I'll uninstall my USB drivers and let XP re-install them after a re-start, since one of the updates could be screwing it up. (I recently installed an optional Windows Update NVIDEA graphics driver and that totally screwed up my screen resolution, so loading the 'latest driver' is not always the best option!)

  tallboy 22:21 28 Oct 2009

Well, I cleared out all my USB drivers and let XP re-install them from scratch. I also uninstalled all the Logitech s/w and camera drivers and re-installed them. I still get the 'Windows Picture Aquisition Wizard has encountered a problem and needs to close' message - even though XP reports the driver as being OK!

I then removed the Hercules camera s/w and drivers from my wife's PC and replaced them with the Logitech s/w and camera. It worked first time! Most frustrating - although I guess at least it confirms that the camera is working OK.

If any other ideas come to mind to fix this problem, please post them here before my wife decides that she'd like to keep the Logitech camera!

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Dell XPS 13 9370 (2018) review

HomePod review

Comment regarder les Oscars 2018 ?