Logitech pro900 will not reinstall

  badgermansix 14:32 31 May 2011

Windows XP Professional Service Pack 3 (build 2600) 2.80 gigahertz Intel Pentium 4 8 kilobyte primary memory cache 512 kilobyte secondary memory cache Hyper-threaded (2 total) Board: P4i65G 1.00 Bus Clock: 200 megahertz BIOS: American Megatrends Inc. P1.40 07/31/2007144.59 Gigabytes Usable Hard Drive Capacity 63.45 Gigabytes Hard Drive Free Space

I am tearing my hair out.

I uninstalled my Logitech Pro9000 software and camera, at least I thought that I had, half a dozen times. But I find that in C:\Program Files, I have a Logitech Folder containing Vid HD that I just cannot remove. I Just keep getting a message " Cannot delete "file name " Access denied, make sure the disk is not full or write protectedand that the file is not currently in use".

I have used Regedit Find, after backing up, looking for and deleting Logitec, towards the end I have found numerous Logitech values, when I attempt to delete them I get a message "unable to delete all specified values"

I have visited Logitech website downloaded the latest software, but on attempting to install I am told I have not enough memory - this is what I have:- Processes: 35, CPU Usage 0% (at this moment) Commit charge: 436M / 1378M, with 17Gbyte free on the harddrive.

If I atttempt to install via the original CD, I am told that I already have a later version installed.

Any advice please, thanks.

  johndrew 16:07 31 May 2011

There is obviously a problem as the software appears to be running.

Does the process or application show in 'Task Manager'? If it does, select it and click on 'End Process' - you may have to do this several times if it restarts - once stopped you should be able to delete the folder.


Have you tried booting into 'Safe Mode' and reinstalling?


Have you tried booting into 'Safe Mode' and uninstalling?


Have you tried moving the folder to the Desktop then rebooting and then trying to delete it?

Once the folder is deleted to should also be able to delete the 'Registry' entries or use such as Ccleaner to do it for you.

Failing all the above you could try using 'Unlocker' to help download link text

  badgermansix 07:32 02 Jun 2011

Sorry for the long delay, in answering, I have been trying to follow the advice given.

I could see nothing in the Task Manager Processes relating to Logitech. I attempted to install via "Safemode" I dragged the Logitech Folder from Program Files to the desktop and then tried to delete them, it worked, thanks. I used WinASO Registry cleaner to check the registry, and also CCleaner.

Checked Regedit - Find - Logitech - Found Folder - LegacyLVPR2MON - open >sub folder - 0000 with "Device Desc" - "REGSZ" " LogitechLVPrMon >Driver" Attempted to delet but got "Unable to delete specified values".

Thanks again, Used suggested Unlocker, also found and changed "Permissions" in the Left hand folders of the Registry, so have now removed everything relating to Logitech, including Logishrd.

I have also completely removed skype to ensure that I was back to square one.

I have tried - msconfig - clean install but keep getting the Message "An access denied error was returned while attempting to change a service. you may need to log on using an Administrator accountto make specified changes"

I the only administrator (I am the only user).

Processes:21 CPU Usage Max 40% on attempting to install. commit charge 224/1378M

When I have attempted to reinstall Logitech I'm told there is not enough disk space (there is 17gbyte free).

So perhaps it is me as Administrator, how can I check on this would you know.

I have also tried to install with the original disk - offline to avoid updatesb ut still get the same problem?


  johndrew 09:46 02 Jun 2011

Try creating a new 'User Account' with full permissions, logon in this account and see if that cures the problem.

Another consideration is malware. Have you done a full scan with a good AV and such as Spyware Terminator and/or Malwarebytes?

  badgermansix 18:46 03 Jun 2011

Unhid the Administrator account and used that. Have done a full scan with Malwarebytes and MSE, all clean. moved to a different USB point. Tried the 6.63MB Logitech.

The install found the camera o.k. I then got a window saying "your system is below spec. for some software features , is the recommended configuration above acceptable?"

I say yes.

it start to downtoad the updates, but come the installation I get the same old message : unable to install the software, could be not enough space, another install in progress etc. etc.

I just do not undertand this, this camera was working fine on this PC, and still does on my laptop, but for some reason I uninstalled it, its so long ago now that I have forgotten why:-((

I have also noticed on line, that others have had the same problem.

Much more and I will find the nearest window and dispose of it!!

  badgermansix 22:31 04 Jun 2011

I don't know.............. I once again removed everything I could find relating to Logitech.abd Skype, moved the Camera to another USB point, ensured that I was offline, and restarted the PC, I got a message "Found new hardware etc." I inserted the original CD and the camera installed o.k. I reinstalled Skype and I am now in the situation where Skype is working fine with the camera. I tried to reinstall the Logitech software, but it still will not install. As I only use Skype I think that I'll live with this for a little.

  johndrew 10:33 05 Jun 2011

Only just got back to the site.

Two possibilities that come to mind given your last post:

Have you tried installing from the CD with nothing in any USB port? It could be the CD is attempting to install to, say, the camera instead of the HDD.

Have you any other camera, or similar, software installed that may be conflicting?

A bit of a stab in the dark, but ...

  badgermansix 16:59 05 Jun 2011

Thanks for the thought Johndrew,

I have just removed the Printer, Mouse and external HD from the USB. restarting, inserted tthe original diskm and got the same result. Also I no other cameras etc installed.

As I said earlier, the camera is now working with Skype, so I am quite happy with that for the time being, it is just that I cannot use the Logitec softwware, but I'll live with that (for the time being!).

  badgermansix 20:55 07 Jun 2011

Sorted. Thanks to yourselves and others. I downloaded an excellent programme called Windows Install Utility

try http://support.microsoft.com/kb/2438651

This programme listed all programmes that were installed on my PC. There were two or three that I did not recognise and looked like prog. versions i.e [] etc.. when I googled these numbers they showed up as Logitec items. They did not show in the Registry because Logitec was not mentioned. That is why, after uninstalling Logitech, cleaning the Registry of Logitech and LWS via Regedit, using Winaso and CCleaner, doing a clean boot etc, Downloading and trying to install Logitech, working off line and trying to reinstall from the original CD, I came to a stage where I was being informed that there was already a version on the PC. i.e [] After deleting these other items listed, Logitech loaded like a dream

The Windows Install Utiliity also brought to light a couple of other progs that I had not used or wanted for a long time.

I hope this will be of help to others.

thanks again.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

iMac Pro review

Illustrator Charles Williams on how to create magazines and book covers

iMac Pro review

Les meilleures prises CPL (2018)