Logitech G400 mouse suddenly stopped working.

  Alpha7530 18:58 26 Aug 2018
Answered

Hello

So i just turned on my system yesterday only to see that it is not recognizing my mouse anymore. It’s just shows this error under device manager.

“Unknown USB device device descriptor request failed error code 43”

I have tried every possible solution on the google yet nothing worked out so far. Some of the solutions i tried are - restarting system, updating drivers, using different usb port, disabling usb suspend from power options etc.

The mouse is not working even in other systems, with same error message. But yet it is so strange that the mouse works flawlessly in all my android smartphones via otg cable. Why is that?

  Govan1x 00:25 27 Aug 2018

Have you tried downloading and using Logitech Unifying Software. or maybe renew the battery on it.Only uses 1 battery on my M310 mouse.

  Alpha7530 01:05 27 Aug 2018

G400 is a wired usb mouse, hence no batteries are required.

  Fruit Bat /\0/\ 09:55 27 Aug 2018

Use USBdeview to remove the mouse from the system and to remove all instances of the driver from the registry - the download link is at the bottom of the linked page.

remove the mouse and Reboot the machine when windows loads reconnect the mouse and windows should find the mouse and reinstall the driver

  Alpha7530 11:11 27 Aug 2018

This mouse is supposed to be plug and play, i don't think it will make any difference. I have tested this with 3 different machines and all shows up the same error. The only thing it works on is an android phone.

  Govan1x 12:01 27 Aug 2018

If it is less than 3 years old contact Logitech they are very good at replacing faulty items.

Click here

Click here

  Alpha7530 16:05 27 Aug 2018

Already past 5 years.

  Alpha7530 16:07 27 Aug 2018

I know it's very old now but i just wasn't expecting it to go down on me so suddenly. It was working fine just the other day till i turned off my system. I don't understand why it's working fine in android environment?

  Maria Kaylene 18:06 27 Aug 2018
Answer

I think the problem lies on the USB chip on the mouse. Maybe it is damaged in some way, so that it’s not working properly with the drivers on a PC.

  Alpha7530 18:32 27 Aug 2018

You're right... I think it's something on the hardware level. I tested the mouse on Ubuntu, it worked fine for 10 min then started acting weird. Pretty soon it wasn't working anymore.. I guess the mouse hardware was beginning to die when windows had failed to recognize it. Now it's totally dead even on Ubuntu and my android phone. Time to buy a new mouse.

It was such a shock to me.. Never know when these things fails on you.. Thank you for all the help.

How do i close this thread?

  rdave13 19:21 27 Aug 2018

Just click on the green " is the answer" by your last post. Good job that it was just the mouse and not the HDD.

What is Markdown?

Markdown lets you add more formatting to your post. Simply type in your post and it will display as written.

If you wish to add bold or italic characters, add a hyperlink to another website, a heading or a horizontal line, simply use the relevent icons above the text input field.

A preview of your post will appear in the grey box below. If you make a change and you're not happy, simply press the back arrow icon to undo.

Post a Reply

4500

Elsewhere on IDG sites

Huawei Mate 20 Pro review: In-depth hands-on

See concept art from groundbreaking video games including The Last of Us, Journey and No Man's Sky

iPhone XR release date, price & specs

Les meilleurs VPN pour Kodi (2018)