Linux printer won't work

  bemuzed 10:30 09 Oct 2005

I'm having another go at getting Linux to work after getting a book. Seems OK but when i try to get a printer to work the installation wizzard gives me a list of interfaces to choose. It has 16 USB (USB1, USB2,.....) but I only have 8 physical interfaces. I choose teh first one. The nearest driver in the list is for a Canon S500 printer whilst my printer ia S520. Wizzard completes but I cannot print anything. Have I chosen right USB interface or is the driver not clsoe enought? Any ideas?

  Diodorus Siculus 10:45 09 Oct 2005

Try turning off the PC.

Remove the printer cable

Turn on the PC

Plug in the cable and ensure the printer is on - many linux versions will pick up on it's presence.

What linux do you use?

  bemuzed 10:58 09 Oct 2005

I tried but no success. I get an error message:

A print error occurred. Error message received from system:

cupsdoprint -P 'canonprinter' -J 'Untitled' -H 'localhost:631' -U 'root' -o ' copies=1 multiple-document-handling=separate-documents-collated-copies orientation-requested=3' '/tmp/kde-Steven/kdeprint_1MWY7XMk' : execution failed with message:

  bemuzed 10:59 09 Oct 2005

I am using MEPIS with 2.6.7 kernel. I am a Linux very novice

  martjc 15:04 09 Oct 2005

...especially with Linux. Linux is infamous, in its many guises, for not recognising the printer. If you have a Canon S520 then you NEED a Canon S520 driver! There are subtle differences between very similar drivers, which Linux picks up on. Try Canon's site. They may be able to a download of a Linux driver or b.advise you on how to get your setup working. If no help is forthcoming, why not try a different version of Linux? There are lots of them available and I've never heard of the one you are using.

Why not try UbuntuLinux? I'll even supply it in two different forms if you're interested. You may e-mail me on [email protected], leaving your details and I'll send you a copy through the mail.

Whatever you decide, good luck.

  bemuzed 18:13 09 Oct 2005

Thanks I tried a driver for a S600 and that seems to work

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

iMac Pro review

Illustrator Charles Williams on how to create magazines and book covers

iMac Pro review

Les meilleures prises CPL (2018)