Limited or No Conectivity

  DAVE1982 21:26 28 Jun 2008


I would appreciate any help you guys can give me with the following issue.

I have 2 PC's - The first is a Desktop running Windows XP and is connected to my Belkin Wireless Router via an Ethernet Cable - The second is a Laptop running Windows Vista and connects to the internet wirelessly via the router.

I setup the router a couple of months ago and have been running the internet on both PC's ever since with no problems at all.

Then for some reason, seemingly overnight, the internet connection to the desktop PC has stopped working! (The laptop PC can still connect to the internet and seems to be uneffected).

After investigation I found that the desktop PC is showing the following error:

'Limited or No Conectivity'

I have tried shutting down the PC, disconnecting the modem etc all to no avail.

I also tried clicking on the 'repair' button in Windows but got the following message:

Windows could not finish repairing the problem because the following action can not be completed:

Renewing your IP Address.

I am now stuck for ideas on how to get past the problem and would appreciate some advice.



  Joe R 21:41 28 Jun 2008


the first thing I would try, is go to device manager and uninstall your ethernet card, reboot, and let windows reload the drivers.

Can you access the router?

  chub_tor 21:46 28 Jun 2008

This problem has been extensively discussed in the Networking Forum. A search produced the following links - you should find a fix from one of them.

click here

  sinbads 22:01 28 Jun 2008

Try a system restore to when your connections worked

  The Kestrel 23:57 28 Jun 2008

I have just had the same problem with my wife's PC. The problem was solved by removing the network connection in network connections (control panel) and then reinstalling the connection from available networks. You will need to have your WEP or other encryption key available when you reinstall the connection. This completely cured the problem and all has been OK since.

  Sealer 09:26 29 Jun 2008

Hi Dave. I cant believe it, you have exactly the same problem as i had yesterday click here
Dont know how or why but i turned on pc this morning and all is back to normal??? Very strange but have a look at my thread, it may help. Good luck

  DAVE1982 10:31 29 Jun 2008

Hi All,

Thanks very much for your quick responses!

After reading some of the threads you directed me to I have tried using the comand prompt when I typed ipconfig/release I got the following information:

Connection-specific DNS Suffix :
IP Address :
Subnet Mask :
Default Gateway :

When I typed ipconfig/renew I got the following message:

An error occurred while renewing interface local area connection : unable to contact your DHCP server. request has timed out.

I hope this means something to someone as i'm quite out of my depth now!



  brundle 10:36 29 Jun 2008

Have you checked the cables and connections?

Reset TCP/IP; click here

  DAVE1982 10:37 29 Jun 2008

Yeah all the cables are where they should be and have not been fiddled with recently...

  chub_tor 10:52 29 Jun 2008

click here gives a way of fixing the "Unable to contact your DHCPserver"

  DAVE1982 11:03 29 Jun 2008

Thanks chub_tor I have tried the suggestions in your link to no avail.

However I have noticed that if I click on the details button in the local area connection status box I am given the following information:

Physical address : 00-08-02-BE-6B-C0
IP Address :
Subnet Mask :



This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Honor 9 Lite review

How Social Media has Propelled Political Graphic Design and Art in the Last Decade

The best kids apps for iPhone & iPad 2018

HomePod d’Apple : date de sortie, prix et fiche technique