Lenovo M92p won't boot and no output with GPU

  Kenducis 08:28 04 Jan 2018
Locked
Answered

Hello. I recently bought a used Lenovo M92p. It booted just fine and recognized my GPU with no issues, but the BIOS had a password so I had to reset the CMOS. After that it booted to bios but my display remained black. I tried plugging it to motherboards display port but still no image. So I tried unplugging everything and booting with one ram stick and it booted to bios. After putting it back I understood that the issue was GPU. As soon as I plugged in the GPU it won't display anything. I tested it on another PC and the GPU was fine(it's a Quadro 2000D if it helps) so I tried my other spare GPU's including GT 210 but the same result. So I ignored the need for GPU and tried booting it without. All of my installation USB's ended up with winload.exe and winload.efi errors(tried to boot both UEFI and Legacy) and all of my DVD's just got stuck at Windows logo and wouldn't even display the loading circle or any error message. I am stuck. I tried to download multiple ISO's from multiple sources with no luck. I have heard that Lenovo motherboards come with some sort of security stuff that can prevent it from booting but I have no clue what it is and how it works. Please help since I have ran out of ideas. Thanks

  Fruit Bat /\0/\ 10:52 04 Jan 2018
Answer

click here is probably what you were meaning about motherboard restrictions.

Because it came with win 7 I assume it might not then recognise a win 10 boot media.

As for the GPU BIOS problem I think you might need to do a BIOS Flash to the latest available for your board.

  Kenducis 11:17 04 Jan 2018

Would the bios flash resolve the Windows 10 issue or am I stuck with Windows 7?

  Fruit Bat /\0/\ 18:30 04 Jan 2018

If it had 10 on it then you should be able to connect to the MS site where you download boot media and update the PC as it will be registered on MS servers

If its never been updated then you will need to purchase a win 10 key from MS but still use the update route.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Samsung Galaxy Book 2: Release date, price and specs

This First Man soundtrack vinyl cover art is exquisitely composed

How to watch Apple’s October 2018 iPad launch

Meilleurs VPN (2018)