Lenovo Flex 2.14 not turning on!

  lucyjude 18:08 16 Dec 2015
Locked

The other day my lenovo flex 2.14 (running on windows 10) went into what I can only assume was sleep mode: the power light was flashing (which the usermanuel says indicates sleep mode).

I read somewhere that taking the battery out and holding the power button for 30 seconds would help (something to do with draining charge or something). I couldn't get access ot the battery as I didn't have any screws so I took the charger out and tried the same thing, put the charge back in and hey presto it seemed to work.

  • Then the same thing happened again a few days later, but the same solution didn't seem to work. This time I managed to take the back off - but then didn't know where the battery was. I carried on pressing the power button and disconnected any wires that I could see (turns out these were the ones to the wireless card) and reconnected them. At some point the sleep button turned off and wouldn't turn on again, at this point I put the charger back in and the computer started working again.

  • Then , a few days later, the same thing happened AGAIN, this time I worked out where the battery, but couldn't work out how to disconnect it. While I was fiddling with it trying work out how to do so (I should point out that I never managed to disconnect it) the sleep light turned off and wouldn't turn on again. I plugged the charger in, still nothing would turn on or off, I screwed the battery back in place and HEY it turned on.

  • I had to travel to London the next day, turned my laptop off (or so I thought), put it in a soft shell case, put that case in my suitcase and set off. When I next got my laptop out and tried to turn it on the power button was flashing again like it was in sleep mode. I took the back off, took the battery out (but didn't connect the wired because I didn't know how), put it back and then left it over night.

When I woke up the sleep light was still blinking. I took the battery out, worked out how to disconnect the wire, pressed the power button for thirty second, reconnected the battery and plugged the charger in. Now it won't turn on at all.

The only thing that happens is when i put the charger in, the battery charge light shines solid white.

I've detailed everything I've done because I'm not really sure what has fixed this problem the first few times.

CAN ANYONE HELP ME. I realise I would be best to take it to PC World, but I have 2 assignments due over christmas and can't really spare the two weeks that they will take it away from me for.

currently borrowing other people's computers and its very stressful.

Everything I have is saved on onedrive so losing content isn't a problem - thankfully.

  xania 14:36 17 Dec 2015

I am a little concerned that you have been mucking about with all those cables without knowing what you are doing. Having had a quick look at the manual, I can't see how you get to the battery, but sometimes this is intentional. Certainly, it seems that power is getting to the battery, but, I suspect, not beyond that, which implies either that the battery is not making contact, or the on/off switch has become faulty. Either way, I am not sure that you can fix the problem and you may have to take it to your vendor to service.

NB In case you don't have it, you can download the manual here;

click here

  xania 09:47 18 Dec 2015

I agree dalsmiok, except I fear that what has already been done may have invalidated any warranty. But you can always try!!

  scotty 10:47 18 Dec 2015

Do you see error messages as you try to shut down indicating that Windows cannot close an app? I have seen this and the computer does not fully shut down, just goes into a sleep mode which still drains the battery.

  rdave13 21:55 20 Dec 2015

If still within warranty take it back to the retailer and say it doesn't work any more. Regardless of your work pressures you have to follow the rules on warranty repair (ahem) and accept the time scale.

Always have another laptop/PC/ (hard drive) as backup. Laptops are cheap as chips if you don't do gaming.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Xiaomi Officially Launches In The UK

Inside the concept art behind Nicolas Cage's most bizarre film, Mandy

MacBook Air 2018 review

Comment supprimer un compte Facebook ?