Laptop seems to be stuck in sleep mode

  GilletteFusion 02:15 24 Apr 2017

Hello there!

I'm trying to fix my friend's Lenovo IdeaPad 100-15iby.
He accidentally tripped over the USB cord that was connecting the laptop and his phone, and at that moment the laptop just went kaput (the phone is ok btw).
The power LED on the laptop just keeps blinking, the manual says that the blinking LED indicates that the laptop is in sleep mode.
When I connect the AC adapter the battery LED turns on, which is what it normally does.
Holding the power button for more than 5 sec turns it off.
Holding the power button for more than 5 sec, with the AC adapter plugged, in briefly turns it off, and then it goes back to being all blinky and stuff.

I opened up the laptop and have tried the following:
-disconnecting the battery and holding the power button for 30 sec
-clearing CMOS
-reseating the RAM stick
-pressing the NOVO button

Also the CPU gets hot when it stays in the sleep mode for a while. I'm really scratching my head over here; it's a curious problem it seems

Thanks for your time

  Fruit Bat /\0/\ 11:51 24 Apr 2017

Tried connecting to an external monitor? just to make sure its not a graphics problem.

  GilletteFusion 13:25 24 Apr 2017

Thanks for the reply. I tried connecting it to another monitor, the issue still remains

  wee eddie 14:00 24 Apr 2017

As Laptop USB Sockets are sometimes Soldered to their MOBO, there is a possibility that he damaged/cracked the MOBO, when he yanked the connection.

  GilletteFusion 14:08 24 Apr 2017

Checked every part of the MOBO, nothing looks cracked, or damaged in any kind of way, nothing looks like it got burnt, even the USB port itself is without a scratch.

  wee eddie 14:13 24 Apr 2017

When you say "He accidentally tripped over the USB cord".

How hard did it actually hit the floor? Tiles or Carpet?

  GilletteFusion 14:18 24 Apr 2017

Well, the laptop didn't fell. When he tripped over it, the phone fell to the floor, but it's perfectly fine. So when he yanked the cord the laptop just went blank. It's really weird I know

  wee eddie 15:13 24 Apr 2017

That sounds as if there is a small crack in the MOBO, although why it's having the effect it is, is beyond me.

MOBO replacements are possible, if the parts are still available. A cracked MOBO, if that is what it is, sounds terminal to me or, at the very least, almost as expensive as buying a new Lappy

  wee eddie 15:14 24 Apr 2017

Now, with any luck, someone will come up with a better solution

  GilletteFusion 15:17 24 Apr 2017

Yeah, I've been trying to find a solution for hours now. But it seems that it's done for. Thanks for your help

  wee eddie 16:24 24 Apr 2017

Don't give up. I have frequently found that, shortly after I post a simplistic solution, some wise old bird disagrees with me, and posts something that has more chance of working

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Honor View 20 review

How Esports branding got a brand new look

Best free Mac apps

Les meilleurs VPN gratuits (2019)