Laptop Problems, OS Related.

  [DELETED] 14:34 20 Jun 2006

I've recently noticed a few operating system errors (I think) since recovering my computer to factory settings (basically a clean install). The Laptop is an Acer Aspire 3003WLMI and these are the first problems I've had since getting it at Xmas.

The problems are:

Error on shutdown - A message box pops up reporting what I believe is a driver error (.dll) however it is gone within less than a second so I can't fully read the message.

The LAN Icon on the taskbar shows the Wireless Network Connection (aquiring network address icon). However the actual Wireless Network Icon Works as normal.

Windows Update Site requires me to install Macromedia Flash, but once downloaded, and I click on the install icon and select the Installation langauge, no further install messages appear.

I've downloaded the latest updates for XP Home SP2 from the Microsoft Update site.

Thanks for anyhelp, I know these are not major concerns, but they could be bugging after a while!

  [DELETED] 18:53 20 Jun 2006

This should be in the Helproom, but now that you've posted here, don't duplicate it.

Your message refers to a Dynamic Link Library file (.dll), not a driver issue. You need to run sfc /scannow and let it do its thing silently - it won't tell you anything, but all being well, it will find the problem file and replace it.

If that doesn't work, there are ways and means, but we'll cross that bridge if/when required.

  Forum Editor 23:44 20 Jun 2006

this to the Helproom.

  Taff™ 23:47 20 Jun 2006

Start Button>Run and type "sfc /scannow" into the box.

  woodchip 23:51 20 Jun 2006

Go into device manager and check if you have any yellow icons.

Right click My Computer\Properties\Hardware\Device Manager

  [DELETED] 15:41 21 Jun 2006

Thanks for everyones help, this problem has now been solved.

  [DELETED] 16:10 22 Jun 2006

I marked this problem as "solved" too early.

After running the svc/ scannow option the incorrect icon was fixed however the error message still appears on shutdown (although not all the time, only every couple of shutdowns), which is why I thought the problem was solved.

The message is something along the lines of

"The application failed to initalize ...." , still disappears too quickly to fully read the message.

I searched google typing in what I had cought of the error message, and got pages suggesting it was to do with the .net framework. I've installed .NET Framework 2.0 but the problem still exists.

I've also checked that all the laptops drivers are ok. Do you think the recovery partition of the hard disk is corrupted? If so I have recovery on CD which I could also try.

  [DELETED] 16:35 22 Jun 2006

If you think it may be related to .Net, uninstall it altogether. I have yet to find a reason for this program's existence.

  [DELETED] 13:29 23 Jun 2006

I decided that the easiest way to read this message would be to take a photograph of the screen on shutdown, using my digital camera at a fast ISO. I successfully captured the message which actually reads:

"Application Failed To Initialize because windows station is shutting down"

Now that I had the full, correct message I entered it into the Windows Knowledge Base / Support Site to find out the cause of the message. It appears that because I have Microsoft Office 2000 installed on a computer with Windows Desktop Update and I am using I.E. 6.0. on XP SP2 this message will occur.

This problem is apparently known by Microsoft but their is no solution to get the message to go away. However I can continue to use my PC as normal without any problems with Office or other applications.

For more information you may also wish to read the knowledge base article, located here:

click here


  [DELETED] 20:12 24 Jun 2006

Why, does this message keep on reappearing?

I decided to remove Office 2000 completely to hopefully get rid of the message as it was outdated anyway, and instead am using Works and Office 2007 beta for basic productivity tasks.

It appears that Office isn't the only program generating the message "Application failed to initalize because windows is shutting down". This time I caught what was causing the message in the title bar:


After doing a search in Google I found out that this is a vital running process from Kerio Personal Firewall, so I can't terminate that process.

Their must be some underlying error causing these programes to apparantly crash on shutdown. Any ideas? I've got Event Viewer open but don't really understand it if anyone could explain this.


  [DELETED] 08:19 13 Jul 2006

I too have had this issue. However, it is simply a bug in Kerio. Apparently it is not happening on ALL win XP puters and we are reassured that it is in no way dampening the effectiveness of the firewall. Nor is it in any way causing any harm to your system. They now have a patch for it or you can juat wait a week or 2 for the new build which is what I would recommend. This kind of thing is to be expected until they get all the "bugs" worked out after aquiring the firewall and now adding to it to make it thier own.
Here is a link to others that have also had this problem.
click here
I think this is the best firewall on the market myself. It ran a close second to Sygate Pro but since that is gone, this 1 rules! :)

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

How to watch the World Cup for free on TV and online

Meet Superfiction, the little design studio with a load of character

Best Mac buying guide 2018

Comment résoudre les problèmes de connexion internet d’un iPhone ?