Laptop ignores headset microphone for built in one

  LittleSatyr 06:28 10 Jul 2018

Hello! I am not by any means a tech wizard, so this issue is honestly driving me insane. I have a Razer Kraken pro v2 headset, and an Acer aspire VX 15 laptop with windows 10. They have worked perfectly fine together since I got them. That is, up until a few days ago.

After a windows update, my microphone started acting weird, and I couldn't for the life of me figure out why it was picking up the sound from my cooling table when I was recording something. I solved it by unplugging it, and didn't think more of it.

Then when I got into a call with my boyfriend yesterday, he pointed out that the sound was much more hollow than usual, and when I moved away from my laptop, it got harder to hear. And after some testing, we figured out that my laptop is completely ignoring the microphone on the headset. It doesn't even react when I switch the microphone off on the headset. We tried it on my phone, and it works fine. And it does the same with other old headsets I have.

I went trough a bunch of articles about this, none were my exact problem, but I decided to still give them a go. Some solved it by updating their sound drivers, I did that. Nothing. Others solved it by turning on the microphone in the privacy settings, mine was never turned off. Others solve it by picking the headset microphone in their list of recording devices. I only have one option, and I have always only had one option, and never had any issues until now.

Now, I do still have the built in microphone, so I'm not completely without. However, that thing picks up every single click of a button and amplifies it by an insane amount, so I can't type while in a call. I can't play games while in a call either, and I would much prefer to have this fixed.

Does anyone have any solutions that would possibly help solve this? The only thing I haven't tried is to roll back the update, but I have no idea how to do that, and would prefer not to fiddle too much with those things if I don't have to. Any help appreciated!

  Fruit Bat /\0/\ 19:16 10 Jul 2018

Windows update sometimes replaces the sound drivers with generic windows sound drivers ( updating just updates the wrong drivers

You need to download the drivers for your sound card (chip) from the manufactures site e.g. Realtek

then uninstall the current sound driver and install the new driver

  LittleSatyr 15:47 11 Jul 2018

Thanks for the suggestion, but that didn't work either. I tried it just now and I still have the exact same issue. I might have done something wrong when installing it, but I removed the old drivers as instructed, and downloaded the new ones directly from realtek, and the problem is still there.

  Fruit Bat /\0/\ 16:45 11 Jul 2018

I see your sound chip a realtek this is the correct driver for your machine click here try installing it and see if it solves the problem.

  LittleSatyr 19:11 11 Jul 2018

That doesn't seem to have worked either. I tried to uninstal and instal those drivers twice, the problem still persists.

  LittleSatyr 19:22 11 Jul 2018

Okay so, I have run into another issue it seems. The old drivers aren't being properly uninstalled. Everytime I reboot, the old ones are back.

  LittleSatyr 20:07 12 Jul 2018

Oh my god, okay problem solved. I didn't need to uninstal things, the problem was that my computer has changed my settings to only see my headset as headphones, and so also ignoring my microphone completely.

It works perfectly fine now. I am honestly relieved and also frustrated that it was that easy to fix.

What is Markdown?

Markdown lets you add more formatting to your post. Simply type in your post and it will display as written.

If you wish to add bold or italic characters, add a hyperlink to another website, a heading or a horizontal line, simply use the relevent icons above the text input field.

A preview of your post will appear in the grey box below. If you make a change and you're not happy, simply press the back arrow icon to undo.

Post a Reply

4500

Elsewhere on IDG sites

Xiaomi Mi 8 Review

Adobe confirms it’s working on a full Photoshop for the iPad

Apple announces new MacBook Pros for 2018

Qu’est-ce qu’Amazon Prime ?