Laptop DVDRW Drive I/O Error - Argh!

  Radix Lecti 22:50 24 Sep 2008

Evenin' all,

I'm trying to fix a friends laptop (unsuccessfully thus far), and wondered whether anyone could assist, or if they'd come across this issue before.

Packard Bell EasyNote B3605, AMD Sempron 3000+, 512MB ram, SlimType SOSw-852s DVDRW Drive, Win XP Home SP3.

Whenever I try to open the drive up in My Computer, I get an error message which says:

"D:\ is not accessible. The request could not be performed because of an I/O device error."

In device manager there are no issues being displayed, and I've tried removing the drive in Device Manager, and then using 'Add Hardware', which leaves it in the same state.

Any ideas?

  Fried~Chips 23:16 24 Sep 2008

but not 100% on if this will fix. Their is a download tool from microsoft to fix a registry issue something related to the filters in the registry which effect the optical drives but you would have to go search. I will try and find it also.

  Fried~Chips 23:26 24 Sep 2008

it may fix it. Its from Microsoft Help & Support Article ID: 169620 you can find the following using the search D:\ Is Not Accessible

1. Go to Start & Run
2. Type in Regedit then click on OK.
Navigate in left pane HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Enum\Root\Legacy_Cdrom\0000.

3. On the Registry menu, click Save key and call it 000.reg.
4. Go to

5. Click the 0000 key, and then click Permissions on the Security menu.
6. Change the 0000 key permissions to Everyone : Full Control, and then click OK.
7. On the Registry menu, click Restore, and restore the 000.reg key saved from step 3 on top of the current 0000 key under Legacy_cdfs.
8. Under the restored 000 key, modify the following two entries:a. Change DeviceDesc:REG_SZ:Cdrom Device to Cdfs Device.
b. Change Service:REG_SZ:Cdrom to Cdfs.

9. Exit Regedt32.exe and then restart Windows NT. The CD-ROM drive should now work normally.

  Fried~Chips 23:27 24 Sep 2008

but I have used this to fix XP problems before.

  ambra4 23:31 24 Sep 2008

Update the firmware

click here

  Radix Lecti 09:39 26 Sep 2008

Thanks for that. Unfortunately, the registry doesn't have a 'HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Enum\Root\Legacy_Cdrom\0000' section. There's no Legacy_Cdrom directory at all, although the latter mentioned Cdfs entry is there.

Thank you for the link. I've updated the firmware without issue, however this appears not to have addressed the issue.

Any more ideas lovely people?

  Radix Lecti 12:02 27 Sep 2008

Hi all, sorry to bump, but I need to get this laptop back to it's owner on Monday :o\

  Radix Lecti 18:00 04 Oct 2008

Another shameless bump.

I've tried removing the drive physically now too, and re-inserting, but I'm still getting the same error.

Any more thoughts?

  skidzy 18:29 04 Oct 2008

Try resetting your DMA settings.

This can be caused by the system currently in PIO mode over DMA.
DMA reset tool click here

Or via device manager;

To enable DMA mode using the Device Manager


Open Device Manager.


Double-click IDE ATA/ATAPI Controllers to display the list of controllers and channels.


Right-click the icon for the channel to which the device is connected, select Properties, and then click the Advanced Settings tab.


In the Current Transfer Mode drop-down box, select DMA if Available if the current setting is "PIO Only."
If the drop-down box already shows "DMA if Available" but the current transfer mode is PIO, then the user must toggle the settings. That is:

Change the selection from "DMA if available" to PIO only, and click OK.

Then repeat the steps above to change the selection to DMA if Available.

  skidzy 18:35 04 Oct 2008

Just a small reminder;

If the solution is the DMA or PIO settings and will only work within PIO mode (very slowly) there is a good chance the drive is on its way out.

I would expect Ambra's advice to cure the problem if the burner is in good shape.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Dell XPS 13 9370 (2018) review

Creative studio Omnibus' brand identity for We Said Enough fights back against sexual misconduct

WWDC history: Apple's product launches since 2005

Espace de stockage : comment libérer de la mémoire sur votre iPhone ?