LAN network works but the wireless doesn't.

  greybeard 23:08 01 Aug 2009
Locked

Running a Toshiba Sattelite with XP home and a Belkin ASDL modem with wireless router.
About 6 months ago, I set up my wireless router using my laptop.
As per instructions, I used a lan wired connection initially, but never managed to set up the wireless network.
I can run both the laptop with xp/IE, and a desktop with Ubuntu/EMC2/Firefox successfully on a lan network.

I turned off the laptop firewall, relying for the moment on the router's own firewall, and changed the Tools/Internet Options/Connection setting to "Dial whenever a network connection is not present", and opened IE which immediately gives me a connection to the web.(I'm typing this via the lan at present)
However, if I remove the lan cable, reboot, switch on my laptop wireless card, and try to open the IE browser, it tries to dial up, and gives me an error window.

Right clicking on the wireless icon shows that it is detecting and connected to the correct network, but that's as far as I can get.

What am I doing wrong, or have omitted to do ?

I've tried setting the connection to "Never dial a connection", but that makes no difference.
I've been to Belkin's site, but no specific support for this problem, ditto user manual.

I've tried changing channels, as per Belkin's suggestion, but no difference.
As we are very isolated here, I wouldn't expect there to be any interference causing the problem, and for the same reason, I'm content to turn off the security settings, but nothing I've tried so far has made any difference.
I've run the network diagnostic tool, which gives me information, but unfortunately not much guidance, apart from consult the manufacturer.
The firmware is up to date.

Any suggestions, apart from get a new router !
John

  greybeard 08:06 02 Aug 2009

Ambra4 - Many thanks for your extensive help.
I shall print it off, and have a go.
Regards
John

  greybeard 19:24 02 Aug 2009

Well I ran through your instructions, and came across a couple of glitches en route, possibly some more info, but no further forward.

First glitch.
In the para "Other LAN card setting", my type of lan card/Configure/Advanced tab, "Connection type" isn't displayed, nor is "Flow Control".
There is an entry "Link Speed/Duplex mode" which has an Auto setting, and a "Network Address" entry which is ticked as "Not present".
Several other entries, but they don't appear to relate to the present problem.

Second glitch.
Laptop settings allowed the connection to the router, with the icon on the taskbar correctly identifying the wireless network.(I've currently got the security disabled)
Wireless Network Connection Properties/Advanced doesn't show an AP (Infrastructure)Network Only entry.
It has "Internet Connection Sharing", with an entry "Allow other network users to connect through this computer's Internet connection" , currently unticked.

As an experiment, I ticked this, and looking at the settings which then showed a choice of nine services, IMAP, POP3, telnet, HTTP etc, none of which are ticked.

Third glitch.
On the Wireless card type/Configure/Advanced tab, "Auto connection Mode" doesn't appear.
There is an unticked entry for Wireless device off, then a list of properties -
Ad Hoc Tranmit power; Data Rate; Power Management(no Cam mode, only highest performance, relating to power usage);Preamble(default value is auto - preamble length negociated with the AP)


That's how it is at the moment. I tried OK'ing all, rebooting etc, but now progress.
Regards
John

  greybeard 21:35 02 Aug 2009

Second glitch resolved - I hit the advanced tab, not the advanced button, as you requested.

Alas, first and third glitches still extant, but I continue to try.
John

  greybeard 23:13 02 Aug 2009

Ad hoc Transmit Power is set at Default, highest power.
The Data Rate is set at Default - with "Best Rate" greyed out.
The available settings are -
"Best Rate,1Mb/s,2,5.5,or 11Mb/s"

Regards
John

  greybeard 23:39 02 Aug 2009

Unfortunately, no.

In order to try, I have to unplug my adsl wire from my wired modem, change it over to the router, wait for everything to stabilise, then switch the wireless card on.
Always remembering to change the tools settings from never dial to always dial.
It's a bit of a performance, so I hope I'm not making mistakes as I do it.
I think tomorrow I will try setting up another laptop with a wireless card, and see if I can get that one to talk to the router.
I also have desktops that I can try with usb wireless adaptors, so at least I can get more of an idea if it points to the problem being in the router, or me !
Goodnight, and au revoir,
John

  greybeard 09:24 03 Aug 2009

Up to the present, I connect the laptop to the internet via a Sagem ADSL modem.
To get a wireless connection, I'm setting up a Belkin router which has an internal modem.
Up to yesterday, I could only get a router connection to the web via a lan lead from the laptop to the router, with the router connected to my phone socket via the ADSL lead.

Qustion. If I have the lan line connected, laptop to router, with the router connected to the internet, can I switch the laptop wireless card on, and select the wireless connection without unplugging the lan lead ?

I assumed I can't, so this is why I have been moving leads about.

This morning I tried to set up the router with the laptop via the lan connection, but now it can't connect via the lan line either, even though it was working ok last night.

I'll go and do something else for a while.
Then I'll start again, going through your instructions plus amendments.
Regards
John

  greybeard 15:22 03 Aug 2009

All goes to plan until I remove the lan cable. That's when the connection goes down.

Let's say I'm on the pca site via my lan network, but with the wireless icon showing, and hovering the mouse over it gives "Connected, sig strength excelent". If I then remove the lan cable, as soon as I try to refresh the page, or go to another page, I get the "Not Available" window.

Re your earlier instructions.

When I right click on the wireless icon, then click Status/general/properties, click Wireless Networks tab, the box "Use Windows to configure my wireless network settings" is ticked.
Is this OK ?

In the Status/General-Properties/general tab, if I select (TCP/IP)/properties, it shows "Use the following IP address", and gives the correct address for the router - 192.168.2.1 - but the "Use the following DNS server" is selected, but left blank.
Is this OK ?

Regards
John

John

  greybeard 16:18 03 Aug 2009

Ooops - I've just checked, and that IP address is not what it gives.
The "Use the following address" gives 192.168.0.1 as the entry.
Sorry for the error.

Is this significant ?

John

  greybeard 17:45 03 Aug 2009

As I thought, and not as I had set them up earlier, so I was suprised to find them like this.
I'll explore again, change them back to the auto setting you ask for in this window, and see what happens.
John

  greybeard 17:53 03 Aug 2009

By George, I think we've done it.
I'm typing this on a wireless connection.
I right clicked the wireless icon, went the TCP/IP properties, and reset the two settings to automatic and then pulled the plug out.

So far so good, and very many thanks for your patience and guidance. I've learnt quite a lot in the process !
Kind regards
John

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Mi Mix 3 UK Review: Xiaomi's Flagship Slides Into The UK

12 character artists you should know about in 2019

iPad mini 5 release date, price & specs rumours

Test : l’enceinte Bluetooth BW-AS2 de Blitzwolf