Kodak Imaging will not start

  Prewch 10:51 15 Nov 2005

I have not used Kodak Imaging for some time but needed to use it today.

It will not start and gives the following error messages which trying to reinstall does not cure.

"A device attached to the system is not functioning."

When I click it it reveals another message

"The IMGCMN.DLL file is linked to missing export MFC42.DLL:6453"

I upgraded my scanner about a year ago. Could this have caused the problem?

Ta in advance for any help.


  ventanas 11:48 15 Nov 2005

Assuming your using Win98 what would have happened is that mfc42 has been replaced by another version during a program installation. I can recall a time back in the days of Win95 when I had seven different versions of this file stored in programs root folders because each one needed a different version. You will need to find a way to reinstall Kodak to put the version of mfc42 it requires back. I can't remeber now if there is a way. But if you do this you will probably find that the program that caused it to be replaced will stop working. So copy it somewhere else first. When something complains copy into that apps root folder.

Hopefully someone will know how ro reinstall Kodak.

  ventanas 11:59 15 Nov 2005

Just had a thought. A bit of a long shot, but you could check your System folder to see if previous versions got renamed instead of replaced. See if there is anything named mfc42.bak or .old and change the extension. You will have to move the existing file though.

  ventanas 12:05 15 Nov 2005

Solution from Kodak click here You do need to reinstall.

  ventanas 12:06 15 Nov 2005

More info click here

  Prewch 12:11 15 Nov 2005

Many thanks for help.

You were right I am running win98SE.

Will try to sort the problem out later by following up your leads.

  Prewch 16:46 15 Nov 2005

Have tried the Kodak deinstall - reinstall with no success.
Have also tried the SFC method again without success.
I have found 5 copies of MFC42.dll on my machine in C:\Windows,C:\Windows\System, C:\Windows\AOLshare\sysinfo, C:\Programme Files\Kodak\KODAK Picture CD\PCD, and finally C:\Programme Files\Grolier Interactive\GME2003.

So which one is causing the Kodak Imaging problem by being "missing"



  ventanas 16:59 15 Nov 2005

Either C:\Windows\System or, more likely C:\PF\Kodak, But a program should always look in its own folder first before going to the System folder. When you uninstall does it completely remove Kodak, or is the folder still there with files in it?

  Prewch 17:47 15 Nov 2005

When I uninstall Kodak Imaging from the accessories items, then use find to locate MFC42.dll its still in all the folders it was before. ie there are 5 copies as in my previous response


This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Dell XPS 13 9370 (2018) review

Creative studio Omnibus' brand identity for We Said Enough, a non-profit against sexual misconduct

What to ask Siri on the HomePod

Meilleurs VPN (2018)