Keyboard Problems

  Bangell 00:56 29 Oct 2014

Hi, recently my laptop's integrated keyboard stopped working properly. Some key bindings refused to work, or were mapped to other characters, or most commonly typed multiple characters e.g. 'help me' is hue30lpme0 (spacebar doesn't work). I could do nothing to fix this and suspect it is very probably a simple hardware problem; the thing is getting old and full of crap.

So I bought a standard Microsoft Wired 600 USB keyboard and am trying to use it, but it too has all sorts of problems. Firstly, I cannot use two keys in combination; shift or ctrl plus another key has no effect, and I tried a videogame in which the same thing happened; I could not perform any more than one function at a time on the keyboard. Those brackets above had to be done with the laptop keys, as well as this exclamation mark! Secondly, the USB keyboard is not very responsive. I have to slowly press one key at a time, and therefore cannot type very fluidly. This is infuriating right now.

Could anyone help - I'm not even able to disable the laptop keyboard so I don't know where to begin with figuring this out. Thanks in advance.

  john bunyan 10:01 29 Oct 2014

My grand daughter has had 2 new laptop keyboards (I suspect moisture or make - up splash) with your symptoms. I bought the keyboard from the link below and a friendly local repair man fitted them (I thing you could do it yourself, with care and help from U Tube!

I tried a link but got a "we think this is spam!

Here is a copy of the supplier.

Google for link!!

  Bangell 20:40 29 Oct 2014

I'd like to see if I can get this USB keyboard working - essentially it refuses to type if more than one button is being pressed at a time.

  Bangell 21:46 29 Oct 2014

This doesn't work for me; the disable option is greyed out, and the uninstall option tells me that it'll take effect upon restart - and when I restart, the laptop keyboard is still working.

  Bangell 00:10 31 Oct 2014

The only reason I want to disable the laptop's integrated keyboard is to see if doing so restores normal functionality to my USB keyboard, where I cannot press more than 1 key at a time. If anyone has any advice on how to resolve the 1-button-at-a-time problem with my USB keyboard, or the multiple and misassigned characters on my laptop keyboard, I would be very grateful.

  wee eddie 00:53 31 Oct 2014

I am sure that I am misunderstanding you but, why do you wish to be pressing two keys at the same time.

Will it not respond to "Cntl, Alt, Del" or have I missed your point entirely.

  Bangell 00:56 31 Oct 2014

No, ctrl alt del does nothing. I cannot use two keys together e.g. using shift and 1 for an exclamation mark. Also I have to type very slowly because a new character cannot be typed before the previous key has been fully released. So if I try to type normally I get the first letter and then nothing because the keys are being pressed too quickly.

  wee eddie 01:59 31 Oct 2014

So, you can't change case for a single letter, like 'I', or is there just a considerable time lag?

  SparkyJack 10:06 31 Oct 2014

This is getting complicated, as various actions seem to contradict..

hen the 'native k-board fails,it can be the board.

When an external(USB or wireless)board show Sam symptoms then the problem must lay elsewhere.

It was mentioned that Ctrl/Salt/Del does not work. That is a M/S Windows function.

It does not work in a Linux archtechure---Ubuntu--forcexample.

So tell us more about the machine and operating system.

  Bangell 10:38 31 Oct 2014

The symptoms of the laptop and USB keyboard are quite different. The laptop keyboard has keys which type nothing, type the wrong letter, or type multiple letters. The USB keyboard types correctly but refuses to input a new letter unless the previously used key has been fully released, meaning I have to type with a far longer delay between strokes than normal. The reason ctrl alt del does not work is because simply typing this function requires more than one key used at a time; in the same way, shift plus 3 does not type a pound sign.

I am using Windows 7, fully updated legit copy, and I have the most current drivers for USB and my keyboard. It is a Medion Akoya P6815.

  SparkyJack 11:50 31 Oct 2014

The following Malay give you a clue.

I have an aniet Toshiba Satellite 100 that came my way as a non runner.

The keyboard although query carried extra symbols on the keys,but it typed OK .

When I looked up the specs for info ,all the links came up in reek.

I have looked op your median, all thhe links are in German.

So go to control panel/keyboard and check the setting. It is possible the default is German

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

HTC U12 Plus review: Hands-on

Brilliant (and Weird) World Cup 2018 Art and Design Projects

Best Android emulators for Mac

TV & Streaming : comment regarder Roland Garros ?