IP address for printer

  Sapins 11:57 24 Jun 2012

Where do I find the IP address for my epson RX620 printer.

I have windows 7 on a desktop connected through a Netgear DG834G v2 router, with the printer connected by USB, it works wirelessly, with my laptop and and now I want use it wirelessly with my iMac which asks for the IP address of the printer, I have looked everywhere but I cannot find it. While I still have most of my hair and my sanity can anyone tell me exactly how to find this IP address please.

  KRONOS the First 12:21 24 Jun 2012
  KRONOS the First 12:25 24 Jun 2012

Sorry for using the Google thing, but someone did it to me and I really think it is a bit of fun.

  Sapins 12:34 24 Jun 2012

Already tried Google and Netgear help and iMac help and Epson help!!

  rdave13 13:17 24 Jun 2012

Run Belarc on your laptop see if it shows the printer and IP address.

  Rayuk 14:18 24 Jun 2012

Have you tried with the laptop on and check in router for attached devices which should show printer address.

  Woolwell 14:20 24 Jun 2012

It will be listed in your router's configuration pages. Unfortunately I am not familiar with Netgear routers.

Alternatively in W7 Open Network and you should see the printer listed, right click on and select and properties and at the bottom of the windows will be the IP address.

  KRONOS the First 14:25 24 Jun 2012


Since this question was posted I have wondered about my Epsons IP address and thanks to you I now Know. Though I might add that it is necessary to click on See full map then hover mouse cursor over the printer.

  Woolwell 14:42 24 Jun 2012

You can have a problem with dynamic allocation of IP addresses by the router and when the next time the PC and printer are switched on it looks for the old IP address which is now incorrect. I do not have this problem with my Epson wireless printer but I have allocated a static IP address to my Lexmark laser.

Chronus - I was using Network - not Network and Sharing Centre.

  Sapins 15:49 24 Jun 2012

Belarc taking a long time to load! Stuck on 96%! will to load again.

Laptop on and router only shows desktop and laptop.

Network shows printer but properties does not show printer.

  Sapins 16:00 24 Jun 2012

Belarc now lists printer but no IP address.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

iMac Pro review

See iconic duo Smith and Foulkes' epic animation for the BBC's Winter Olympics coverage

iMac Pro review

Idées cadeaux pour geeks et tech addicts