IP address - no internet connection

  Peter-298738 15:57 03 Mar 2007

Have just installed Homeplug to replace a wireless internet connection between two computers. It worked fine last night. This morning, one computer won't connect to the net. First it asked for a password for the internet connection (I hadn't set one). Now, the internet connection isn't working - when I click on "repair connection", it tries and fails to assign an IP address.

The TCP-IP settings on the PC seem to be the same as on the one which is working fine. However, when I run ipconfig /all, I see that the one which works says "IP routing enabled - yes", while the other one says no.

Checking IP routing enabling on the MS help facility shows that I need to edit the registry.

Can this be right? I'm not aware of having changed any settings. Do I really need to edit the registry, which I'm not keen on tampering with? Is there something else that could be the problem?

  brundle 16:10 03 Mar 2007

Not familiar with Homeplug, but even so if you are trying to access the 'net with two computers on the same connection there ought to be a DHCP server to designate IP addresses to both computers.
DHCP: click here
Homeplug: click here

  Peter-298738 16:34 03 Mar 2007

On the DHCP point, I saw a reference in another thread similar to this about checking Start, Run, services.msc to see if DHCP is running, and it is.

It's a cable internet connection, and the Wiki article linked says most cable providers use DHCP. I assume as it's running, the computer should be able to get an IP address - but something is stopping it from happening.

I was getting an intermittent failure to assign IP addresses on both computers when I was using a wireless connection, but this wasn't a problem when I connected the computer which now can't connect direct to the router with a cable. I therefore assumed it was a problem to do with the wireless network, hence the move to Homeplug.

  moorie- 17:26 03 Mar 2007

here is a link i used recently to troubleshoot a network connection,it may be of some help
click here

  Peter-298738 18:47 03 Mar 2007

Thanks for the link.

Where it says "If there is no communication with a DHCP server on the network and no static IP address has been assigned, then the PC will assign itself an IP address in the 169.254.x.x range", that's the IP address which I get.

So DHCP is enabled and is running, but no communication with it?

Any further suggestions gratefully receuved.

  mgmcc 20:43 03 Mar 2007

Not sure what your setup is but, if not using a router and one computer is connected to the internet with the second computer networked to it, you need to enable "Internet Connection Sharing" on the actual internet (modem) connection in the "host" PC. When doing this, you have to select the network adapter with which you connect to the "client" PC. Previously, this would have been the "Wireless Network Connection" but it will now be the "Local Area Connection" as you are now wired to the Homeplug.

When this has been set up correctly, the "host" PC acts as a DHCP server to allocate the IP address to the "client" PC and it will be a 192.168.0.x address.

  Peter-298738 23:07 03 Mar 2007

Setup is that the cable modem is connected to one homeplug device, and the two computers are connected to one other Homeplug each - the internet connection doesn't go via one PC to the other, as far as I can understand. I have a router, but am not using it.

The way they are physically connected hasn't changed since they were both connecting to the internet yesterday. I don't know if this is the way the homeplug stuff is best set up, but with only one ethernet connection on one PC, I can't connect it both to the modem or router and also connect to the homeplug, so that's why I did it this way.

I don't follow how to enable internet connection sharing - can't find an option in the internet connection or network connection menus?

  phono 23:38 03 Mar 2007

You refer to Homeplug, can you supply the name of the device manufacturer and the name or part number of the actual product?

Depending on your answer to the above question there may be no need to enable ICS (Internet Connection Sharing).

  moorie- 00:37 04 Mar 2007

here is a link to fix corrupt winsock it maybe worth running it ,so you can rule it out as an issue

click here

also have you got the firewall turned off in xp aswell as any other firewall.

  moorie- 01:08 04 Mar 2007

these two links were posted on another thread
click here

click here

may be of some assistance

  phono 01:28 04 Mar 2007

I was also thinking of corrupt TCP/IP or Winsock stacks, it seems you have beaten me to it.

Nevertheless, see here click here

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Huawei MateBook X Pro review: Hands-on

The art of 'British' pulp fiction

Best password managers for Mac

TV & streaming : comment regarder le Tournoi des Six Nations 2018 ?