Iomega external hard drive not detected

  br1anstorm 22:45 01 Aug 2016
Locked

I have a new 320GB Iomega portable/external USB2 hard drive, purchased some time ago as a spare, but - until now - not used. So it has no data on it other than whatever might have been on it from the factory.

The fundamental problem is that when plugged in, it does not show up as a drive in the "My Computer" screen. I have plugged it in to different USB ports, and in two separate laptops, one WinXP (yes yes, I know....) and one Win7. The power light on the drive illuminates, and the case vibrates/hums very slightly which suggests that the hard drive is spinning. But it simply doesn't appear as a drive. There are some clues (which I hope forum experts may be able to interpret). See details below. First, I tried to see if there was a hardware problem:

1) I checked the connecting USB cable, by using another different and known-good cable. Same problem: drive not visible. Which suggests the original USB cable is OK.

2) To check if there was a fault in the actual Iomega PCB inside the casing, I opened the case, disconnected and removed the hard drive (it's made by Seagate), and installed it in another, spare, hard drive caddy which I happened to have - and which has its own known-good USB PCB interface. Plugged this into my laptop(s). Still no drive visible or listed in "My Computer" - which suggests that the original Iomega PCB USB interface is not the problem.

So.... is the hard drive dead? It seems to spin OK. Or is there a software issue, or something else? Incidentally all my other external drives, USB sticks and other devices work fine in both my computers, so the laptops themselves are not faulty in any way.

3) I reassembled the original Iomega HDD into its casing, and plugged it in again. As before, I get a popup from the System Tray saying "new USB storage device detected". Then, after a few minutes, a further popup saying something like "Your new device is ready to use". But - as before - still no sign of the external drive in the "My Computer" screen (NB I have no other USB devices or drives connected). So....

4) I open My Computer>Manage and look at Device Manager. No conflicts or warnings are showing under any headings (eg disk drives or USB controllers). Under Disk Drives, when I expand the list, it shows the internal "C" drive (a Fujitsu) and.....another drive which is listed as "ST932032 5AS USB Device". Clicking on the Properties of that device, the 'General' tab says the device is working properly. But under the 'Volumes' tab, the headings say Disk - unknown; Type - unknown; Status - unreadable; Partition Style - not applicable; and Capacity, Unallocated and Reserved Space - all 0 MB.

5) Still in Computer Management, under Storage>Disk Management, the "C" drive shows up as healthy and normal. The (empty) CD/DVD drive is also listed as drive "D". But nothing else. No sign of any other drive in the list or in the graphic which illustrates partitions. So no possibility of right-clicking to initialise, format, or assign a drive letter, because the external drive simply does not appear!

6) last throw of the dice after some online browsing. Using the command line (not something I am comfortable with...) I went to "disk part" and tried "list disk". The only entry was the internal hard disk (ie the "C" drive). No sign at all of the external Iomega drive.

So I am baffled.

The only other clue is that - curiously - the "Safely Remove Hardware" icon in the system tray , when clicked, DOES list 'USB Mass Storage Device' as well as (pointlessly) the CD/DVD drive "D". And when that mass storage device is selected, it shows the ST932032 etc reference, and when clicked, a popup says the device can be safely unplugged.

At present, therefore, this Iomega external portable hard drive is a useless paperweight. But it is frustrating not to be able to pin down the problem. Before throwing it away, I'd like to know if there is anything else I can do to check it, and/or to make it visible and usable.

  Aitchbee 00:59 02 Aug 2016

It might need to be plugged into 2 usb ports, using a y-splitter.

  br1anstorm 01:08 02 Aug 2016

The Iomega drive comes with a two-USB Y-connection cable (one for connection, one for - supplementary? - power). For all attempts to use this drive, I have plugged both the USB connectors into ports.

Indeed I have another identical Iomega 320GB portable drive with the same USB connector(s). It is recognised, and has worked for years without problems, in several computers. It runs well whether only one USB connector is plugged in, or two.

So the use, or not, of a y-splitter doesn't seem to be the cause, nor to explain the problem of non-detection.

  Fruit Bat /\0/\ 09:57 02 Aug 2016

Plug it in and check it shows up in diskmanagement.

from there you can right click and format the drive and allocate a drive letter.

Once that is done it will then show up in explorer.

  wee eddie 10:16 02 Aug 2016

If it has been sitting around for years, maybe it's not spinning up.

Perhaps, raising it's core temperature (something that should be done over 24 hours or more) or a little gentle shaking, might do the trick.

I would advise not doing these things while it is plugged in

  br1anstorm 11:16 02 Aug 2016

Thanks, Fruit Bat, but see point (5) in my original post. The external drive does not appear at all in disk management. So I cannot do anything (initialise, format, assign/change drive letter, etc) with it.
So I'm looking for ideas/guidance on why it is not visible. Once I can "see" it, I hope to be able to do something to make it work!

  br1anstorm 11:19 02 Aug 2016

Thanks, wee eddie - that's worth a try.

But - as I mentioned - the drive does seem to be spinning up. I can hear a faint humming, and the casing vibrates slightly (as do other portable drives when they are running).

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Mi Mix 3 UK Review: Xiaomi's Flagship Slides Into The UK

12 character artists you should know about in 2019

iPad mini 5 release date, price & specs rumours

Test : l’enceinte Bluetooth BW-AS2 de Blitzwolf