Iomega 298GB USB LPHD-UP will not open

  fdm2000 16:51 31 Dec 2015
Locked

I have an problematic Iomega 298GB USB connection/powered external drive - modelLPHD-UP P/N 31769900 The referenced external drive has a Win 7 backup which used the Win 7 backup application. The drive is recognized but when I tried to open the drive I first get a pop-up telling me that I must format the drive before I can use it? When I go to properties for the drive it shows 0 used and 0 unused space. In desperation I tried to run format but got a message telling me that windows is unable to complete the format. I also get a messaged that the location (I:\ is not accessible - data error (cyclic redundancy check) When I go to Control panel, Computer Management - Disk management it shows the Iomega I: drive 298.09 GB and reports it as a Healthy Primary Partition, confusing me even more?

Is this drive now a paper weight or is there any hope for restoring/accessing the drive contents?

Any suggestions or comments would be appreciated.

Frank

  [DELETED] 19:10 31 Dec 2015

Try running CHKDSK on the external drive using CMD, click here.

  fdm2000 16:20 04 Jan 2016

Thanks for the response rdave, Unable to run CHKDSK - Windows does not recognize the drive. Nothing appears to resurrect the drive - methinks it is toast.

Frank

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Mi Mix 3 UK Review: Xiaomi's Flagship Slides Into The UK

2019's best up-and-coming illustrators

New Apple Products 2019: Predicting the new Apple products coming soon

Comment utiliser une manette PS4 ou Xbox One sur votre Mac ?