Internet Explorer (XP) cannot access Webpages

  jeano 23:55 08 Mar 2008

I am trying to help a neighbour whose laptop suddenly stopped connecting to any web page via Internet Explorer. He is running XP home and accesses via a wireless connection to a router. Any URL results in “Page cannot be displayed …” standard page. The wireless connection is active and connected.

So far I have run sfc /scannow, installed and run Spybot search and Destroy, Ad-Aware 2007, Super Anti Spyware and CC Cleaner. Although a few issues were found, the main problem was not fixed. I have also removed Internet Explorer 7, Google Toolbar, AOL toolbar and other unnecessary applications. System restore would not restore to a previous point (3 different date attempts). I thought that IE was corrupt and so I removed Internet Explorer 6 and then reinstalled from the cab files. Still no joy. So I installed Opera to enable him to get on to a web page. This presented with similar errors. Previous threads suggested that winsockxpfix might help so I downloaded the exe from the link but error message states that it is “not a valid Win32 application”.

I have also used his laptop connected to my own router and established an excellent connection but still no functioning browser – either IE or Opera. I have now run out of ideas. Can anyone suggest anything.

  jeano 00:09 09 Mar 2008

Also installed Reg Cure which came up with over 500 "issues". I elected not to fix any of these as CC Cleaner only showed 152 (which I fixed) and then re ran after reg cure showed its results - no further ones were found. How reliable is Reg Cure - I've never used it before.

Also - system restore in safe mode showed only one restore point - all the others had disappeared.

  brundle 00:15 09 Mar 2008

Use `Restore EXE association` click here

clear the cache of the browser before downloading winfsockfix again

dont bother with regcure

  jeano 01:31 09 Mar 2008

Thanks brundle

Downloaded exe association fix for htm/html and installed - no change. Cleared browser cache (on both machines as I am having to download stuff to a memory stick to transfer to the laptop). Ran the 2nd download of winsockxp fix -still the error "not a valid win32 application". This download is from

Anything else I can try?

  LambertD 02:06 09 Mar 2008

Your neighbour is using AOL? If so then see if he can access the site in the AOL browser as I and a few other people had a problem where we could access sites via the AOL browser but not using IE, Opera or Firefox. It is fixed for me now but I think it was a DNS problem. Try changing the DNS to:

  jeano 02:38 09 Mar 2008


No my neighbour's ISP is Sky and mine is Tiscali. Have connected laptop wirelessly to both networks and received confirmation of connection and excellent signal strength - just can't get a browser to function.

  brundle 14:31 09 Mar 2008

Not entirely clear at what point you're getting the error message - when you start the download? If you're transferring files via flash drive there's no need to try the download again. Do other .exe files work or is that when you get the error message you refer to?

  jeano 14:58 09 Mar 2008

Hi brundle

I get the error message when I double click the exe file to run the prog. Is there a way of telling whether there is a problem with winsock? This solution was just one of series of things I tried after looking at other threads where people had problems with IE.

  brundle 15:06 09 Mar 2008

This might help; click here

Does the .exe problem happen with all .exe files or just the Winsock one? Try changing the extension to .com instead of .exe and see if it makes any difference

  jeano 17:03 09 Mar 2008

Hi brundle - tried changing the file extension to .com and same error message was generated.

Followed your link and ran the netsh commands - there was no difference in the before (bad) and after (good) listings. The final command "netsh IP reset" does not exist. The help command does show a "set" option for netsh. I am really struggling now. Thanks for the help so far but am I possibly barking up the wrong tree?

  Fruit Bat /\0/\ 17:22 09 Mar 2008

Check secrity key is correct and firewall is not blocking IE / OE

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Dell XPS 13 9370 (2018) review

No need to scan sketches into your computer with Moleskine's new smart pen

WWDC history: Apple's product launches since 2005

Comment importer des contacts d’un iPhone à un autre iPhone ?