Internet access through browser not working

  dms_05 09:08 23 Nov 2008

I turned my laptop on this morning and found my normal browser (Opera) wouldn't load any pages. So I tried Chrome and then IE7. None will load a page. However if I use the Browser function in IBM Lotus Symphony I can access all pages. Also I have a TV Viewer in my Vista Sidebar and that quite happily plays streamed video from BBC/Sky and so on.

I've changed DNS without any improvement. I've changed from my laptops network card to an external card and see no change.

I've checked my TCP/IP settings.

Anyone any idea about why three major browsers won't work but browser independent functions (like VoIP) do?

  dms_05 10:29 23 Nov 2008

Marg7 - thanks for the response. I've been resetting the Router and trying that. It's really odd - I continue to be unable to even contact the Router through any recognised browser but I can contact it through the browser built into Lotus Symphony.

I've checke things like Lease Dates and they are all current.

Next step is to replace the Router and see if that's the cause.

  realist 11:07 23 Nov 2008

Obvious things I know, but did you try a system restore.

Also could it be a firewall issue?

What av do you have installed? I have had Avast cause me winsock/connection problems.

  T0SH 11:21 23 Nov 2008

Check by hovering your mouse pointer over the small monitor (connection)icons by the clock if with the non working browsers it says Local only and with the working one both Local & Internet

This may help you are some way towards diagnosing the problem

Cheers HC

  dms_05 11:44 23 Nov 2008

Thanks everyone. I have a solution - I've turned off the Automatic allocation of IP address and supplied a manual address and things have returned to normal. I tried Marg7 WinSock fix and ran msinfo32 but all seemed OK. I can now access pages and emails normally. I'm not sure why and if this is a sensible solution but at least it works (at the moment). From what I could see Vista had decided to remove my 192.168.0.x network and substitute a Local one of it's own.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Dell XPS 13 9370 (2018) review

The art of 'British' pulp fiction

Best password managers for Mac

TV & streaming : comment regarder le Tournoi des Six Nations 2018 ?