Intermittent Internet non-access by router

  Nosmas 14:46 09 Aug 2006

My system is XP Home SP2 (MS updates fully up to date)with IE 6. I have recently bought a Toshiba laptop preloaded with XP Home SP2 and have networked the two using a Netgear wireless router WGR614 v6 and AdslNation X-Modem M3.

The networking setup is basically working OK apart from one annoying problem. I use MailWasher (free) and AVG Free. MW is set to check for new emails every 15 minutes and once launched, an icon rests in the notification area. Double clicking on the icon normally displays MW's window and a message appears at the bottom stating how long ago the last check was made. I now find that if there has been no
Internet activity for (say)5 or 10 minutes the message at the bottom reads "Skipped automatic check as there is no Internet connection". This message appears whether MW is freshly launched from the Quick Launch area of the task bar or double clicked from the notification area. However if I refresh an open Internet page or launch a new page and then launch MW, it behaves normally.

A similar thing happens if I right click on the AVG icon and select 'Check for updates'. A message "Could not find default dial-up connection" is then displayed. Again refreshing or opening a new Internet page allows AVG to access Grisoft's site and inform me if there are any updates ready for downloading.

Suspecting a problem or wrong setting with the modem I checked with their Support who suggested running the system with the router disconnected and the modem connected direct to the PC's Ethernet port. If MW and AVG worked normally then he suggested the problem was with the router. I ran that configuration all day yesterday and found MW and AVG both worked normally. As soon as I re-connected the router the problem returned.

Today I contacted Netgear's Support. Although the adviser spoke English it was with a Dutch accent and I am not sure whether he fully understood my explanation of the problem. He said he would need to know the TCP/IP Port being accessed by both MW and AVG and he or one of his colleagues would then be able to instruct me how to open that Port.

Dealing with Ports is getting a bit out of my depth, and I ask where the devil do I get that kind of information? (He said the program provider should be able to supply it; but there is no support for either of these free programs.)Logic tells me that there seems to be something wrong with his diagnosis. If both MW and AVG can connect immediately after Internet activity then surely they must be able access which ever Port is needed? Why then do they 'think' there is no Internet connection after only a few minutes of inactivity?

Would welcome any suggestions either for solving this problem or how I can obtain the required Port numbers.

  Nosmas 14:51 09 Aug 2006

I should have added to the above the fact that although I have not Installed MW on the laptop I do have AVG Free running and there is never any problem with it making a connection irrespective of any Internet inactivity.

  FelixTCat 16:19 09 Aug 2006


First, thank you for providing so much information. Many people approach the forum with a "My pc doesn't work - please help" approach.

Second, I think that your modem router has an option to disconnect the internet connection after a period of no activity. It is in the set-up pages, often where you input the username and password for your ISP. The option is usually of the kind:

Dial on demand (Yes/No)
Disconnect after no activity for [dropdown box] minutes

Find that option and there is normally one to allow continuous operation. Tick that and all should be well.



  ade.h 16:42 09 Aug 2006

I can't push the brain cell into remembering where Netgears have that option in their config, but I will check a manual and let you know if I find it.

Re: ports for Mailwasher. click here Mailwasher is really to be treated just as any other mail client, so should* only need the usual 110 and 25 opened up.

*In theory.

  Nosmas 16:47 09 Aug 2006

Thanks for your reply. You refer to my 'modem router' but since they are separate pieces of kit and you also refer to where I enter the user name I presume you meant to refer only to the modem.

On the X-Modem configuration pages there is nothing about disconnect timing on the page for my account details (only username and password).

On the WAN Settings page it shows: -
VPI = 0, VCI = 38, Encapsulation = PPPoA VC-MUX, PPPBridge = Disabled (alternative Enabled), Disconnect Timeout = 0 seconds (but no dropdown for other selections), MRU = 1500, MTU = 1458, MSS = 1398, Authentication = Auto (alternatives CHAP or PAP), Automatic Reconnect = box ticked.

I think these are the only relevant pages, or can you suggest anything else please?

  FelixTCat 17:51 09 Aug 2006


Thank you; you are quite correct and I apologise - I was referring to the modem. The 2 timeout settings are Disconnect Timeout = 0 seconds (presumably you could type a different number in the box if you wished) and Automatic Reconnect = box ticked.

The 0 seconds means disabled in this sense, i.e. there should be no timeout. The automatic reconnect should mean that if the connection is dropped, the modem should automatically reconnect - in my experience, this never quite seems to happen.

Since these settings are as they should be, you could try 2 more things:

1. set the Disconnect Timeout to, say, 3600 seconds, save the change and restart the modem; then change it back to 0 seconds, save and restart

2. As in 1. above, but don't change it back to 0

Sometimes, to make a setting stick you have to change it to something else, then change it back. Option 2 means that it will time out after an hour of non-use but will then reconnect if you ask it nicely (i.e. by opening a browser window).

You could also try a small program which continually makes an internet connection, such as BySoft StayAlive Pro 3.0, found here: click here or this program, which I haven't tried: click here



  Nosmas 19:35 09 Aug 2006

Tried both your suggestions re setting of timeout but sorry to say they have made no difference. Haven't yet downloaded either of the links you gave.

Doesn't the fact that yesterday without the router connected both MW and AVG behaved perfectly normally, and yet immediately 'misbehaved' when the router was re-connected, point to the router as being the cause of the problem? Also the problem is only with my desktop which is connected by Ethernet cable to the router, whereas the laptop which is wirelessly connected has no connection problems even when there has been no activity for a considerable time. The laptop has been on standby for about six hours and I have just immediately connected to Grisoft's site when I right clicked on the AVG icon and selected 'check for updates'.

  Nosmas 00:00 10 Aug 2006

I think I may be on to something but not quite sure what to do.

I decided to have a look at the Netgear configuration settings. In the basic settings section the default radio button was set to 'No' in answer to the question "Does your Internet connection require a login?". When setting up the network in conjunction with my son (who is more knowledgeable than I on these matters) we had selected the 'Yes' radio button which then displayed different details - Login name (as opposed to username) and password. I have just re-accessed these and they were set as we had left them. In addition there was a box for Idle Timeout which was set to 5 minutes. The Help at the side explained that it would time out if there was no activity for that length of time, but if the 5 were changed to 0 the connection will be kept 'alive' by reconnecting whenever the connection is lost. First I changed the setting to 30 minutes and saved and updated the settings.

However I was no longer able to access any Internet pages - IE said 'Page cannot be displayed', AVG said 'An error occurred when trying to connect to the server. The server name cannot be converted to the IP' and MW showed 'No such host. Ensure the POP3 server is correct'. On the laptop the same messages appeared for IE and AVG and OE said 'Host (ISP name) could not be found'.

I then went back and changed the timeout setting from 30 to 0 minutes but with similar results. In desperation once more I reset the timeout to the original 5 minutes but I am still getting exactly the same error messages. I have had to disconnect the router and connect the modem direct to my PC in order to get on line to make this post.

It seems that the router timeout is something to do with my original problem, but I am now at a loss as to how I can even get back to that position, let alone cure that problem. Any help from anyone will be greatly appreciated.

  FelixTCat 07:40 10 Aug 2006


The question about whether your internet connection requires a log-in and password is a strange in a router that has no modem attached.

What happens if you say NO to the question since, as far as the router is concerned, you don't?

The timeout would seem to be relevant, but doesn't explain why you don't have a timeout on your wireless connection. However, setting it to 0 seconds usually disables it.

Just note the original settings, change them and see what happens.



  Nosmas 21:55 10 Aug 2006

Sorry for the delay in getting back. Have been rather busy today and also preoccupied with all of today's events.

With the help of my son I have managed to get back on line with the router connected in the system. But still the original problem remains. Tried setting MW to check every 4 minutes in the hope this would 'keep alive' the Internet connection, in the same way that one of the downloads you recommended is supposed to do, but that didn't work.

I feel sure that the timeout setting in the Netgear configuration must have something to do with it, although it doesn't seem to affect the laptop's ability for AVG to immediately go to Grisoft's site however long there has been no Internet activity, and the laptop's wireless connection is still going through the router.

Will probably try Netgear's Support again in the hope of someone else there having some new ideas.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Dell XPS 13 9370 (2018) review

No need to scan sketches into your computer with Moleskine's new smart pen

How to use 3D Touch on iPhone

Comment importer des contacts d’un iPhone à un autre iPhone ?