Installed printer tries to reinstall every boot up

  JAS100 12:23 20 Dec 2003

I am running Windows XP Home edition. I have a canon BJC-3000 colour inkjet printer that I connect via the parallel port.

Each time I boot up the 'New hardware detection' screen comes up and the computer tries to install the printer. I then get an error message stating that the installation has failed due to an 'Overlapped I/O in operation' and am then told that the printer may not work properly.

The printer then works 100% perfectly and will even print out the Win XP test page. It also appears in the 'Printers window'

Can anyone tell me how to stop the printer trying to reinstall at each boot up? I have already removed the printer once from the hardware setup and it reinstalled, again working fine but still tying to reinstall at the next boot up.


  Big Elf 13:09 20 Dec 2003

Could be a driver problem. Have you checked Canons website to see if they have an updated driver available?

  vinnyT 13:13 20 Dec 2003

They'll be a more tech way around this but.... My comp does this if the printer is turned on before I boot the machine, if I wait till already booted into windows, then no problem, works just fine.

  wee eddie 13:21 20 Dec 2003

Turn your printer off before the PC.

Turn it on again after you have re-booted fully.

This is my experience as well.

  JAS100 01:49 21 Dec 2003

Thanks for the suggestions but the problem remains the same.

I am not sure if the new driver downloaded from canon has been installed. It down loaded as an .exe file which self extracted. It did not say where it had extracted to.

Also I cannot see the printer listed in device manager.

Any more ideas?

  Djohn 02:10 21 Dec 2003

Have you tried running via the USB connector? if you decide to try this route, un-install the printer and software, then install software first then connect the printer to the PC. j.

  JAS100 10:59 21 Dec 2003

Thanks for all the replies
I wanted to use the parallel port as I wanted to use my USB's for other things.

Problem was solved by using the driver that came on the Canon setup disk for Windows 2000 rather than the one that came with Windows XP.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Moto G6 Play Review: First Look

iPad 9.7in (2018) review

Test : les écouteurs Bluetooth Honor xSport AM61