Installation issue, Belkin PCI to PCMCIA adapter

  [DELETED] 15:32 26 Feb 2006

I have purchased a belkin wireless pre-n network card, it comes with a PCI to PCMCIA adapter card and a PCMCIA netowrk card.

I have installed the PCMCIA adapter into the computer no problems, then i installed the software, when prompted to insert the PCMCIA card i get the following error
"the devive ricoh R/RL/RT/RC/5C475(II) R5C5520 or compatible cardbus controller has detected a cardbus card in it slot, but the firmware on this system is not configured to allow the cardbus controller to be run in cardbus mode. The operating system will currently acceot only 16-bit (R2) pc-cards on this controller."

The card is 32-bit. i have tried the card on a laptop and it works fine. (the laptop is older than desktop)
I presume i need to change a few settings in windows, any help.

I have a compaq presario S4500UK, running XP home

Is it the BIOS that cant accept 32-bit cards??
Can i make operating system changes??
Is bios update simple??

  [DELETED] 18:08 26 Feb 2006

I’m also having issues with the Belkin pre-N desktop adapter on one of my PCs;
click here

Another forum had someone with an issue on his Compaq Pressarios;
click here

Belkin Pre-N Desktop card
Reviewer: TonieV from Ellicott City MD on Fri Nov 04 17:53:41 EST 2005
1 out of 1 found this review helpful

Could not get the card installed due to Cardbus error.
I tried two cards in two different Compaq pressario's
Seems not to be compatible with every desktop. No or bad support from Belkin
Returned the card to the CC.

Someone from London resolved his issue which had the same error message as yours, by upgrading his BIOS.

click here

J.Lovell's problem solved, September 5, 2005
Reviewer: D. R. Judd "robinjudd" (London UK)
I know J.Lovell returned the card because of the message -
"The device Ricoh R5C520 Carbus Adapter has detected a CardBus card in its slot, but the firmware on this system is not configured to allow the CardBus controller to be run in CardBus mode. The operating system will currently accept only 16-bit (R2) pc-cards on this controller."
We had the same problem and message from XP - it was caused by the BIOS of the host Gateway PC not being uptodate. After a flash update of the BIOS from Gateway the card worked OK. So I guess that was J.Lovell's problem as well.
We solved it ourselves - Belkin responded to emails but did not have a solution.

BIOS upgrades are not to be undertaken lightly as any errors would render your MoBo completely useless.
Mine was upgraded via an online facility provided by MSI.
But it was done by an on-site engineer as I did not have the bottle.
He says its easy, but that the online method was far safer.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Amazon Prime Day 2018: Best Deals & Launches

The humble pint glass is redesigned from bottoms up by design legend Sir Kenneth Grange

The best Amazon Prime Day Apple deals 2018

Quel est le meilleur antivirus pour Windows ?