Installation of a Canon Scanner

  trv4n 23:40 21 Oct 2008

Hello I have a Canoscan d1250u2f which worked on XP. I wanted to put it on Vista. I visited the download site on Canon and downloaded "scan gear drivers".
Attaching the scanner I chose these drivers on the 'looking for drivers' messages from the downloaded file when i plugged in the Scanner usb and they have been found and are classed as up to date in the 'device driver tree'

When i press scan on the device a " windows image acqusition service" title bar appears with
" There is no application registered for this event"

I have not installed the original discs as these were for XP. What does this mean and is there a solution, any ideas greatly appreciated as I have just bought a new printer without a scanner built in! thankyou

  ^wave^ 09:35 22 Oct 2008

is this what you have down loaded if not use this
click here=

  chub_tor 11:09 22 Oct 2008

I have d1250u2f working on Vista and the trick to getting it to work for me was to go back to the Quick Start Guide that came with the unit. This shows that you have to have the scanner connected to the PC and switched on BEFORE you install the scanner driver. When I did this (and I used the driver suggested by ^wave^) the scanner was recognised by all my software packages.

  ventanas 11:14 22 Oct 2008

Yep, this method of installation fooled a lot when this scanner came out. I've got two of these and they have to be connected with the PC off first. Switch on and hope that the scanner is detected (it may not be) If not power down completely (including mains) and try again. Usually works second time.
Choose to install from a location, choose your downloaded file and all should be ok.

  trv4n 18:25 22 Oct 2008

thankyou for your suggestions, I was hoping to do this tonight but now have to go out. I will try tomorrow hopefully.I will post success or not Thursday onwards.Many thanks again!!

  trv4n 22:24 23 Oct 2008

not sure exactly what i did, followed your advice,installed a disc also and it has worked.Thank you for your help

  JHibbs 02:38 26 Oct 2008

I've been trying all of these suggestion for HOURS and still keep getting that same message. My system tells me the driver is installed, but when I try to scan the picture, I get the message (There is no application registered for this event). Please help before I toss it ALL out the window!

  chub_tor 09:02 27 Oct 2008

Unless you have a faulty scanner or cable I can assure you that the d1250u2f Canon scanner will work with Vista if you follow the installation instructions on the Quick Start Guide.

Go into Control Panel, Add/Remove programmes and uninstall the Scanner Driver.

Check in Device Manager that the Scanner is not showing, if it is Uninstall it.

Power down or pull out the power cord on the scanner and either reboot or plug the power cord back in and let Windows find the scanner. When the New Found Prompts come up install the Vista Scangear Driver that you have downloaded from the Canon site or use your original disc and then later on go back into Device Manager and update the driver automatically from Windows.

If you follow these steps and the scanner and cable are good then it will work.

  fadviser 09:14 15 Sep 2009

Help please. I use a Canon scanner and have recently started using Vista. The scanner transferred from XP without trouble and was working normally until now.
Each time I click on the 'acquire' symbol a panel pops up headed 'Get pictures from R5C822' and whatever I try I can't get the scanner to move from this point. If I go to 'Sources' in the File area there is a choice between WIA-R5C592 1.0 (32-33) or WIA-R5C822 1.0 (32-32) None of this means a thing to me

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Samsung Galaxy A8 review: Hands-on

Majority of illustrators don’t earn enough to live from, new survey shows

iPhone X problems

Word gratuit : comment télécharger le logiciel de Microsoft ?