Incorrect Windows Version

  Golding 09:12 26 Mar 2006

I am responsible for four computers, all in different locations, all running on Win98SE installed from the same CD (a charitable donation from Microsoft). I want to run a small program (Safeeject) on all four computers. This runs OK on three machines but on the other an error message appears saying "Incorrect Windows Version. This application is for Windows 98 SE only." As far as I can see the system files, registry entries, etc. are the same on all the machines. I have tried running the program in Safe Mode, in case some other program is causing the problem, but the same message appeared. I tried re-installing Windows and the particular program but with no success. I should welcome any suggestions as to the cause of this problem or ways to overcome it.

  terryf 09:36 26 Mar 2006

I have 2 machines both running xp pro sp2 and there are minor differences. Both machines are the same hardware spec but one has been flashed with the latest bios, the other has not.
Don't know whether this is relevant

  Golding 17:47 26 Mar 2006

terryf, Good point, many thanks. I have flashed the BIOS on the troublesome computer and on one of the others but, of course, the computers being of different makes, the BIOS upgrades were from different suppliers. I think I will try to get an even more up-to-date BIOS for the computer with problems.

  woodchip 17:51 26 Mar 2006

Try runninng SFC from Run with 98se CD in comp

  Golding 08:06 28 Mar 2006

Woodchip, Good idea. I had forgotten about SFC. I've now run it but with no success, although it did replace a couple of files. Many thanks.

  woodchip 11:52 28 Mar 2006

Right click My Computer on the Comp and click Properties, check it is 98se not just 98

  Golding 20:28 28 Mar 2006

woodchip, Another good idea but, as I say, the CD has been used to install Win98 SE on three other machines, so it mast be OK.

  johnnyrocker 20:35 28 Mar 2006

ah but have you checked;)


  Golding 08:59 07 Apr 2006

For the record, having eliminated all other possibilities I have come to the conclusion that terryf is right and the problem is caused by the BIOS upgrade which connot distinguish between Win98 and Win98SE. Thanks terryf.

  namtas 09:53 07 Apr 2006

This will unlikely help to resolve you problem but it might give some clue to the problem which seems driver related see Q 18.1

click here

  Golding 09:04 09 Apr 2006

namtar, Many thanks. I have seen this link before. I was in high hopes of a solution when I found a reference on it to a program called "USB Mass Storage Flusher". Unfortunately this program will not run on any of my four computers. The author has tried to overcome this a couple of times but with no success.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

HTC U12 Plus review: Hands-on

Brilliant (and Weird) World Cup 2018 Art and Design Projects

Best Android emulators for Mac

TV & Streaming : comment regarder Roland Garros ?