Incomplete Raid Set! Please press <Ctrl+S> or F4 t

  malith 12:45 18 Dec 2003

I built a new computer just two weeks before. Configurations as followed.
Motherboard ASUS A7N8X DELUXE (with silicon image raid chip 3112A) BIOS flashed & most recent.
Proc AMD 2600 + XP Barton
Ram 256 pc 2700
hard disk Maxtor 120GB Sireal ATA Mode 6Y120MO
Video Asus nvidia Ge Force 4 440 AGP 8X
CD WRITER ASUS RW5224 so on....
After built this computer by my self, I manged to install windows xp on sata Maxtor hard (single Disk 0 ) disk by using silicon image raid driver disk. Everything worked fine; After I bought another Maxtor hard disk (same model) & added that as disk 1 and mirrored by using silicon image raid utility which built in motherboard. So this time I could enter to silicon image raid utility by pressing F4 or CTRL + S. Then I selected option mirror. Under mirror there were two option. 1 quick 2 Background (while windows running) I selected quick (because I don't know them at all. So it was started to mirror at the same time in dos mode and took nearly 45 mints finished the job. After I rebooted the machine it worked fine but I didn't know really I have a mirror image on second hard drive. Finally I removed the sata cable from disk 0(primary) & connected to disk 01 & boot the machine. XP started every thing was fine. Then I reconnected both disk. I don't't know this time whether mistakenly I changed the cable or not. That mean Primary to disk no 1 & secondary ro disk no 0. But machine started; Then I entered to raid utility & change mirroring process to background. (while windows running) After I noticed Several time windows getting slow & one time hanged when I was using Jet Audio Player. One day after suddenly windows hanged up with blue screen while I was connected to net. (I have latest updated anti virus soft ware & windows xp updated one day before)
I didn't notice the error. Then I restarted the computer. Problem began with this. They can't't find the hard disk. In fact BIOS show my hard disk model correctly. But silicon image raid utility first show my hard disk model & say press F4 or CTRL + S to enter raid utility. When I pressed F4 or CTRL+ S it says
Incomplete Raid Set! Please press Ctrl+S> or F4 to enter Raid Utility
0 Maxtor 6y120Mo

Incomplete Raid Set! Please press Ctrl+S> or F4 to enter Raid Utility
>>>i hit F4 again and I get

No device detected, Utility disabled!
Press any key to continue....

Then I went to Asus website. I didn't't find a solution. I have flashed BIOS with most recent version already (No any updates available 10/06/2003) . Then I went to Maxtor site. There were very nice utilities.
1 Power Max .
This support Sata hard disk too. With this u can check for errors then format so on. I checked my hard disk. Every thing was OK ; Also it could find my hard disk. Also I did low level format. All the test was passed. But still BIOS not recognized Maxtor hard disk. Then I tried 2nd one
2 Max Blaster 3.6
With work like partition magic. U can create copy & delete portion. But this allso failed to find my drive. Also it skip the limitation of the BIOS. That mean U can handle recent big hard disk with old BIOS.
Then I tried silicon image. Ididn't find nothing. But I saw some where in case we replaced the hard disk like disk 0 as disk 01 or disk 01 as disk 0 META DATA COULD OVERWRITTEN BY BIOS UTILITY. I think similar to this something has happened my both disks. I can't't rewrite boot sector of the sata hard disk (Format /mbr) Pls some one tell me how could i over come this problem. I can't't buy a another hard disk again. Pls help. Thanks in advance
Also I tried to install with single drive as I did before with silicon image driver disk. It was not worked; Then I changed boot sequences to SCSI in BIOS. but same. But I could start machine with normal IDE hard disk.

  Chegs ® 15:10 18 Dec 2003

From the look of that,your initial probs were caused by failure of the SATA driver,if you used Maxblast to format the hdd's then chances are thats where the next prob comes from.I have SATA hdd's,they are forever crashing XP,especially since I used Maxblast to format hdd.I eventually got a stable install by ...

a)create a small partition to load OS into.

b)format hdd's using XP cd.

c)d/l latest SATA driver from Silicon Image site

I "found" that Maxblast creates the wrong "cluster" size(although it reckons its Default size)and XP couldn't use hdd(said it was damaged/corrupted)Niether could XP format hdd afterwards.I had to use Maxblast to reformat hdd,then PM/XP to format again,although PM formatted hdd only survived at best three days before refusal to reboot,whereas Maxblast format only lasted at best 3 hours! before XP refused to reboot.

I use mine in "striped" cfg,when I finally get all my vid files sorted,I was going to try "mirrored" RAID.

  malith 15:45 18 Dec 2003


Thanks for your reply. My problem is hard disk(s) not recoerganize raid utility or Xp at all. So how can I format hard disk using Xp cd??? Only Power Max Use to identify them.

  Chegs ® 16:15 18 Dec 2003

To install XP,set to boot from cd-rom/press F6 to install SATA driver(from floppy)then XP will check for previous versions of XP.At some point will appear a message offering to format hdd's in NTFS/Fat32(Quick will do)Then,once XP has created partitions/formatted hdd,it will go on to install itself where-ever its supposed to go.I would think that XP created partition on one drive will be copied over to the "mirrored" hdd.I wouldn't install XP to a big unpartitioned hdd,as I tried this when I 1st got SATA mobo,and I got alsorts of weird behaviour(apps creating errors during install,XP "forgetting" data,etc)

  malith 16:38 18 Dec 2003

No Chegs... I tried this before. Xp can't find harddisk & say there is no drive attached to the system F3 to exit. (Yes ofcourse I used silicon image driver disket by pressing F6 & drivers were loaded )

  Chegs ® 18:48 18 Dec 2003

Looks like you need to run Maxblast to format the hdd,then rerun install of XP,and during install,format from XP cd.

If you have already done this previously,I dunno what else to try(unless you have PM on a floppy and can format from this,or perhaps a 98se floppy,but FDISK has probs with large hdd's)The Maxblast cd I have seems to alter the MBR on the hdd's,although just how/if I haven't found yet.I just cannot get any of the setup/repair tools in XP to work on a hdd thats had Maxblast near it.I also had probs with PM floppys as I created these on an IDE system,and initially PM couldn't "see" the SATA hdd's.

  malith 20:36 18 Dec 2003

hi chegs

My problem is this. Only maxblaster program could find my hard disk. Yes I formated; But there were no any option to alter MBR. After I quit maxblaster same as before. XP or silicon image raid utility couldn't find the drive. I think master boot record altered or some what by raid utility before hanged; Now I'll have to recreate it to identify by XP. But I don't know a utility which capable to do this job since maxblaster doesn't offer such a option.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

iMac Pro review

Illustrator Charles Williams on how to create magazines and book covers

iMac Pro review

Les meilleures prises CPL (2018)